summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-05-25 13:22:02 +0300
committerKent Fredric <kentnl@gentoo.org>2019-07-10 20:13:00 +1200
commit19f6b8c827f9212ccd27e7d24de21c07630ecac2 (patch)
tree76bac0990f64cdf5430a6ca43821981f76595b25 /dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild
parentnet-dns/nsd: Bump to version 4.2.1 (diff)
downloadgentoo-19f6b8c827f9212ccd27e7d24de21c07630ecac2.tar.gz
gentoo-19f6b8c827f9212ccd27e7d24de21c07630ecac2.tar.bz2
gentoo-19f6b8c827f9212ccd27e7d24de21c07630ecac2.zip
dev-perl/Net-SSLeay: Bump version to 1.880.0
- Restore previously broken tests - CFLAGS repsect logic reworked for upstream tooling changes - LIBDIR respect logic reworked for upstream tooling changes - NETWORK_TESTS handling logic reworked for upstream tooling changes Upstream: - Clarify licensing to be consistently Artistic-2 - Improved OpenSSL 1.1.1 support - Improved TLS 1.3 support - Fixed memory leaks in cb_data_advanced_put Bug: https://rt.cpan.org/Ticket/Display.html?id=106314 Bug: https://rt.cpan.org/Ticket/Display.html?id=128207 Closes: https://bugs.gentoo.org/556010 Closes: https://bugs.gentoo.org/684308 Closes: https://bugs.gentoo.org/686730 Closes: https://github.com/gentoo/gentoo/pull/12101 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Stefan Strogin <steils@gentoo.org> Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild')
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild
new file mode 100644
index 000000000000..9d69832552c8
--- /dev/null
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=CHRISN
+DIST_VERSION=1.88
+DIST_EXAMPLES=("examples/*")
+inherit multilib perl-module
+
+DESCRIPTION="Perl extension for using OpenSSL"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl test minimal examples"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warn
+ dev-perl/Test-NoWarnings
+ )
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.88-fix-network-tests.patch"
+ "${FILESDIR}/${PN}-1.88-fix-libdir.patch"
+)
+PERL_RM_FILES=(
+ # Hateful author tests
+ 't/local/01_pod.t'
+ 't/local/02_pod_coverage.t'
+ 't/local/kwalitee.t'
+)
+
+src_configure() {
+ if use test && has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ export NETWORK_TESTS=yes
+ else
+ use test && einfo "Network tests will be skipped without DIST_TEST_OVERRIDE=~network"
+ export NETWORK_TESTS=no
+ fi
+ export LIBDIR=$(get_libdir)
+ perl-module_src_configure
+}
+
+src_compile() {
+ mymake=(
+ OPTIMIZE="${CFLAGS}"
+ OPENSSL_PREFIX="${EPREFIX}"/usr
+ )
+ perl-module_src_compile
+}