summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-05-25 13:22:02 +0300
committerKent Fredric <kentnl@gentoo.org>2019-07-10 20:13:00 +1200
commit19f6b8c827f9212ccd27e7d24de21c07630ecac2 (patch)
tree76bac0990f64cdf5430a6ca43821981f76595b25 /dev-perl/Net-SSLeay/files
parentnet-dns/nsd: Bump to version 4.2.1 (diff)
downloadgentoo-19f6b8c827f9212ccd27e7d24de21c07630ecac2.tar.gz
gentoo-19f6b8c827f9212ccd27e7d24de21c07630ecac2.tar.bz2
gentoo-19f6b8c827f9212ccd27e7d24de21c07630ecac2.zip
dev-perl/Net-SSLeay: Bump version to 1.880.0
- Restore previously broken tests - CFLAGS repsect logic reworked for upstream tooling changes - LIBDIR respect logic reworked for upstream tooling changes - NETWORK_TESTS handling logic reworked for upstream tooling changes Upstream: - Clarify licensing to be consistently Artistic-2 - Improved OpenSSL 1.1.1 support - Improved TLS 1.3 support - Fixed memory leaks in cb_data_advanced_put Bug: https://rt.cpan.org/Ticket/Display.html?id=106314 Bug: https://rt.cpan.org/Ticket/Display.html?id=128207 Closes: https://bugs.gentoo.org/556010 Closes: https://bugs.gentoo.org/684308 Closes: https://bugs.gentoo.org/686730 Closes: https://github.com/gentoo/gentoo/pull/12101 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Stefan Strogin <steils@gentoo.org> Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Net-SSLeay/files')
-rw-r--r--dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-libdir.patch27
-rw-r--r--dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-network-tests.patch17
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-libdir.patch b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-libdir.patch
new file mode 100644
index 000000000000..d78acb9c6153
--- /dev/null
+++ b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-libdir.patch
@@ -0,0 +1,27 @@
+Bug: https://bugs.gentoo.org/416339
+
+The previous patch for the above bug report used $ENV{LIBDIR} but this
+wasn't enough to help with cross-compiling. We could use $ENV{SYSROOT}
+but this results in a bogus RPATH entry. It is better to simply trust
+the toolchain, which may have its own sysroot applied.
+
+Cross-compiling Perl modules requires additional hackery but at least
+that hackery will work now. :)
+
+Chewi
+2017/12/03
+
+diff -Naur a/Makefile.PL b/Makefile.PL
+--- a/Makefile.PL 2017-10-13 01:38:01.000000000 +0100
++++ b/Makefile.PL 2017-12-03 10:52:27.304861804 +0000
+@@ -141,10 +141,8 @@
+ cccdlflags => '',
+ };
+ for ("$prefix/include", "$prefix/inc32", '/usr/kerberos/include') {
+- push @{$opts->{inc_paths}}, $_ if -f "$_/openssl/ssl.h";
+ }
+ for ($prefix, "$prefix/lib64", "$prefix/lib", "$prefix/out32dll") {
+- push @{$opts->{lib_paths}}, $_ if -d $_;
+ }
+
+ my $rsaref = $self->ssleay_is_rsaref;
diff --git a/dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-network-tests.patch b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-network-tests.patch
new file mode 100644
index 000000000000..a98c4c8a0c9c
--- /dev/null
+++ b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-network-tests.patch
@@ -0,0 +1,17 @@
+diff --git a/Makefile.PL b/Makefile.PL
+index 31d9c74..91ac2b4 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -12,11 +12,7 @@ use Symbol qw(gensym);
+ # the Net-SSLeay loadable object on Windows
+ my $win_link_statically = 0;
+
+-my $tests = prompt(
+- "Do you want to run external tests?\n".
+- "These tests *will* *fail* if you do not have network connectivity.",
+- 'n',
+-) =~ /^y/i ? 't/*/*.t t/*/*/*.t' : 't/local/*.t t/handle/local/*.t';
++my $tests = ( 'yes' eq ( $ENV{NETWORK_TESTS} || '' ) ) ? 't/*/*.t t/*/*/*.t' : 't/local/*.t t/handle/local/*.t';
+
+ my %eumm_args = (
+ NAME => 'Net::SSLeay',