summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-21 01:22:25 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-21 01:42:43 +0200
commite661a626199c0dd06f4b94b6af10ca07f5b950c8 (patch)
tree53b033f891c8b427b495ea80fa2ceb70f8eb5ca4 /dev-perl/Olson-Abbreviations/Olson-Abbreviations-0.40.0-r1.ebuild
parentapp-text/aspell: drop old version (diff)
downloadgentoo-e661a626199c0dd06f4b94b6af10ca07f5b950c8.tar.gz
gentoo-e661a626199c0dd06f4b94b6af10ca07f5b950c8.tar.bz2
gentoo-e661a626199c0dd06f4b94b6af10ca07f5b950c8.zip
dev-perl/Olson-Abbreviations: EAPI=8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Olson-Abbreviations/Olson-Abbreviations-0.40.0-r1.ebuild')
-rw-r--r--dev-perl/Olson-Abbreviations/Olson-Abbreviations-0.40.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Olson-Abbreviations/Olson-Abbreviations-0.40.0-r1.ebuild b/dev-perl/Olson-Abbreviations/Olson-Abbreviations-0.40.0-r1.ebuild
new file mode 100644
index 000000000000..88d6ad36312b
--- /dev/null
+++ b/dev-perl/Olson-Abbreviations/Olson-Abbreviations-0.40.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ECARROLL
+DIST_VERSION=0.04
+inherit perl-module
+
+DESCRIPTION="Globally unique timezones abbreviation handling"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/Moose
+ >=dev-perl/MooseX-ClassAttribute-0.250.0
+ dev-perl/namespace-autoclean
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-perl/List-MoreUtils
+ virtual/perl-Test-Simple
+ )
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+ use test && perl_rm_files t/pod.t t/pod-coverage.t
+}