summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-24 20:43:20 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-24 21:40:58 +1300
commitc958e68754f8facc23193853a40adb63d896776a (patch)
tree13afafc2939f9472c6fb6fee601c6236414ef2f4 /dev-perl/PAR/PAR-1.14.0-r1.ebuild
parentsys-libs/timezone-data: version bump to 2017b (diff)
downloadgentoo-c958e68754f8facc23193853a40adb63d896776a.tar.gz
gentoo-c958e68754f8facc23193853a40adb63d896776a.tar.bz2
gentoo-c958e68754f8facc23193853a40adb63d896776a.zip
dev-perl/PAR: Remove unused rdep on Module-Signature
Confirmed by upstream, no code uses this since 2008 Bug: https://rt.cpan.org/Ticket/Display.html?id=120722 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/PAR/PAR-1.14.0-r1.ebuild')
-rw-r--r--dev-perl/PAR/PAR-1.14.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/PAR/PAR-1.14.0-r1.ebuild b/dev-perl/PAR/PAR-1.14.0-r1.ebuild
new file mode 100644
index 000000000000..7cda641192fa
--- /dev/null
+++ b/dev-perl/PAR/PAR-1.14.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RSCHUPP
+DIST_VERSION=1.014
+inherit perl-module
+
+DESCRIPTION="Perl Archive Toolkit"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-solaris"
+IUSE="minimal"
+
+RDEPEND="
+ !minimal? (
+ virtual/perl-Digest
+ )
+ >=dev-perl/Archive-Zip-1.00
+ >=virtual/perl-AutoLoader-5.660.200
+ >=virtual/perl-File-Temp-0.50.0
+ >=virtual/perl-IO-Compress-1.300.0
+ >=dev-perl/PAR-Dist-0.320.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+"
+src_test() {
+ perl_rm_files 't/00-pod.t'
+ perl-module_src_test
+}