summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-02-20 01:08:37 +1300
committerKent Fredric <kentnl@gentoo.org>2017-02-20 02:11:45 +1300
commit8647861c308241c1b41cc6b44d193d4247c3312f (patch)
treea61139a7fbdf14bdde1188ea7d03c26577d56661 /dev-perl/PDF-API2/PDF-API2-2.31.0.ebuild
parentdev-libs/libbsd: amd64 stable wrt bug #609978 (diff)
downloadgentoo-8647861c308241c1b41cc6b44d193d4247c3312f.tar.gz
gentoo-8647861c308241c1b41cc6b44d193d4247c3312f.tar.bz2
gentoo-8647861c308241c1b41cc6b44d193d4247c3312f.zip
dev-perl/PDF-API2: Bump to version 2.310.0
Upstream: - Fix problems reading objects in object streams in large PDFs - Don't get stuck in infinte loops reading corrupt dictionaries - Correctly set max-object number in file stream cross-references - Fix bugs reading TIFF images with stripes wider than image - Fix dash() and renderingintent() bugs - Add support for reading PNG, GIF and PNM from filehandles - Fail early when a referenced file can't be opened - Add preference options "-simplex", "-duplexfliplongedge", "-duplexflipshortedge" - More consistently use temp files as caches when reading streams larger than 16MB - Add support for reading Numbers, Booleans and nulls from object streams - Objects inside large object streams no longer require loading entire stream into memory - Low-level new_api methods deprecated - Avoid crashing when adding annotations to a page with existing certain annotations - Give useful die() errors when files can't be opened Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl/PDF-API2/PDF-API2-2.31.0.ebuild')
-rw-r--r--dev-perl/PDF-API2/PDF-API2-2.31.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/PDF-API2/PDF-API2-2.31.0.ebuild b/dev-perl/PDF-API2/PDF-API2-2.31.0.ebuild
new file mode 100644
index 000000000000..663fdbe752e8
--- /dev/null
+++ b/dev-perl/PDF-API2/PDF-API2-2.31.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SSIMMS
+DIST_VERSION=2.031
+DIST_EXAMPLES=( "contrib/*" )
+inherit perl-module
+
+DESCRIPTION="Facilitates the creation and modification of PDF files"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=virtual/perl-IO-Compress-1.0.0
+ dev-perl/Font-TTF"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_test() {
+ perl_rm_files t/author-*.t
+ perl-module_src_test
+}