summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-24 13:54:14 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-26 21:48:01 +1300
commitef5266e09a0e483ec2b4636eb36d48fe18b841d9 (patch)
treec75bb687023309cf6aa9e9ac3dcc216879f8d1ab /dev-perl/PDF-API2/PDF-API2-2.33.0.ebuild
parentdev-ruby/rubygems: add 2.7.4 (diff)
downloadgentoo-ef5266e09a0e483ec2b4636eb36d48fe18b841d9.tar.gz
gentoo-ef5266e09a0e483ec2b4636eb36d48fe18b841d9.tar.bz2
gentoo-ef5266e09a0e483ec2b4636eb36d48fe18b841d9.zip
dev-perl/PDF-API2: Bump to version 2.33.0
Upstream: - Fix Bank Gothic core font - Weaken references for garbage collection improvements - Remove warning for ambiguous call to CORE::open - text_{fill_,}justified now adjust word-space instead of character space stretching. - Fix buffering for multiline embedded indirect comments. - Fix open(filename)->stringify - Fix off-by-one calculating text width - Fix synfont Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/PDF-API2/PDF-API2-2.33.0.ebuild')
-rw-r--r--dev-perl/PDF-API2/PDF-API2-2.33.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/PDF-API2/PDF-API2-2.33.0.ebuild b/dev-perl/PDF-API2/PDF-API2-2.33.0.ebuild
new file mode 100644
index 000000000000..a1132a91efc7
--- /dev/null
+++ b/dev-perl/PDF-API2/PDF-API2-2.33.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SSIMMS
+DIST_VERSION=2.033
+DIST_EXAMPLES=( "contrib/*" )
+inherit perl-module
+
+DESCRIPTION="Facilitates the creation and modification of PDF files"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="examples test"
+
+RDEPEND="
+ >=virtual/perl-IO-Compress-1.0.0
+ dev-perl/Font-TTF"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Memory-Cycle
+ )
+"
+src_test() {
+ perl_rm_files t/author-*.t
+ perl-module_src_test
+}