summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2020-11-02 19:52:40 +0000
committerKent Fredric <kentnl@gentoo.org>2020-11-10 05:50:05 +1300
commit74847a9190c96b5158a9be20b6e49173c284ab85 (patch)
treebda9da900213f44bbf3671bfc56483387a88a00b /dev-perl/PDF-Builder/PDF-Builder-3.19.0.ebuild
parentgui-libs/wlroots: drop old 0.10.x (diff)
downloadgentoo-74847a9190c96b5158a9be20b6e49173c284ab85.tar.gz
gentoo-74847a9190c96b5158a9be20b6e49173c284ab85.tar.bz2
gentoo-74847a9190c96b5158a9be20b6e49173c284ab85.zip
dev-perl/PDF-Builder: new package, version 3.19.0
Required as a future dependency of media-gfx/gscan2pdf Closes: https://github.com/gentoo/gentoo/pull/18113 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/PDF-Builder/PDF-Builder-3.19.0.ebuild')
-rw-r--r--dev-perl/PDF-Builder/PDF-Builder-3.19.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/PDF-Builder/PDF-Builder-3.19.0.ebuild b/dev-perl/PDF-Builder/PDF-Builder-3.19.0.ebuild
new file mode 100644
index 000000000000..666775ff16d0
--- /dev/null
+++ b/dev-perl/PDF-Builder/PDF-Builder-3.19.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PMPERRY
+DIST_VERSION=3.019
+DIST_EXAMPLES=( "contrib/*" )
+inherit perl-module
+
+DESCRIPTION="Facilitates the creation and modification of PDF files"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Font-TTF
+ virtual/perl-IO-Compress
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Memory-Cycle
+ )
+"
+
+PERL_RM_FILES=( t/author-{critic,pod-syntax}.t )