summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-27 13:38:56 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-27 21:09:52 +1300
commit6302ee6cf776016c21e331233e4614d4c1b9062a (patch)
tree87e3de4973d1e8448db697e1587b57436c30bf7b /dev-perl/PGPLOT/PGPLOT-2.210.0-r1.ebuild
parentdev-perl/PDL-Transform-Color: Add missing CPAN remote-id's (diff)
downloadgentoo-6302ee6cf776016c21e331233e4614d4c1b9062a.tar.gz
gentoo-6302ee6cf776016c21e331233e4614d4c1b9062a.tar.bz2
gentoo-6302ee6cf776016c21e331233e4614d4c1b9062a.zip
dev-perl/PGPLOT: EAPI6 + Tests
- EAPI6ify - Enable tests - Fix test failures due to '.' in @INC - Ensure tests render to NULL device instead of XSERVER Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/PGPLOT/PGPLOT-2.210.0-r1.ebuild')
-rw-r--r--dev-perl/PGPLOT/PGPLOT-2.210.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-perl/PGPLOT/PGPLOT-2.210.0-r1.ebuild b/dev-perl/PGPLOT/PGPLOT-2.210.0-r1.ebuild
new file mode 100644
index 000000000000..482486e167ff
--- /dev/null
+++ b/dev-perl/PGPLOT/PGPLOT-2.210.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KGB
+DIST_VERSION=2.21
+inherit perl-module
+
+DESCRIPTION="allow subroutines in the PGPLOT graphics library to be called from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sci-libs/pgplot
+ >=dev-perl/ExtUtils-F77-1.13"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.21-no-dot-inc.patch"
+ "${FILESDIR}/${PN}-2.21-null-render.patch"
+)