summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-24 14:39:38 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-26 21:48:02 +1300
commitb3b28c7cc29ca8d5184d88ad74119ebca3601c24 (patch)
tree264d7a9f1056647a04aaf7be752896dff48604f2 /dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.420.0.ebuild
parentdev-perl/PDF-Create: Bump to version 1.430.0 (diff)
downloadgentoo-b3b28c7cc29ca8d5184d88ad74119ebca3601c24.tar.gz
gentoo-b3b28c7cc29ca8d5184d88ad74119ebca3601c24.tar.bz2
gentoo-b3b28c7cc29ca8d5184d88ad74119ebca3601c24.zip
dev-perl/POSIX-strftime-Compiler: Bump to version 0.420.0
- Add missing CPAN remote-id's Upstream: - Add musl strftime support Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.420.0.ebuild')
-rw-r--r--dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.420.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.420.0.ebuild b/dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.420.0.ebuild
new file mode 100644
index 000000000000..90761177613b
--- /dev/null
+++ b/dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.420.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KAZEBURO
+DIST_VERSION=0.42
+DIST_EXAMPLES=( "eg/*" )
+inherit perl-module
+
+DESCRIPTION="GNU C library compatible strftime for loggers and servers"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test minimal"
+
+# POSIX -> perl
+RDEPEND="
+ !minimal? ( dev-perl/Time-TZOffset )
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-Time-Local
+"
+
+# CPAN::Meta::Prereqs -> perl-CPAN-Meta
+DEPEND="
+ >=dev-perl/Module-Build-0.380.0
+ virtual/perl-CPAN-Meta
+ ${RDEPEND}
+ test? ( >=virtual/perl-Test-Simple-0.980.0 )
+"