summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-15 09:31:43 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-15 00:06:37 +0100
commite0cd0857c25ad6432261d80495cb03571ed2ef8c (patch)
treef7f9d739930759c8d7fd0b380ca2f88dc4d348cf /dev-perl/Pango/Pango-1.227.0.ebuild
parentdev-perl/PadWalker: Bump to version 2.200.0 (diff)
downloadgentoo-e0cd0857c25ad6432261d80495cb03571ed2ef8c.tar.gz
gentoo-e0cd0857c25ad6432261d80495cb03571ed2ef8c.tar.bz2
gentoo-e0cd0857c25ad6432261d80495cb03571ed2ef8c.zip
dev-perl/Pango: Bump to version 1.227.0
- EAPI6 - Add support for testing under virtual-X11 - Add USE="examples" NB: and gtk-perl X11 Test dependencies only pulled when both USE="test -minimal" are set, because "test" being set doesn't necessarily mean you want to pay the price for the heavy, optional extra stuff. ( And gtk-perl is a bit slow to install ) This way, you can continue using FEATURES="test", but you can save yourself some effort and still get good test coverage if you have USE="minimal" in your environment Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Pango/Pango-1.227.0.ebuild')
-rw-r--r--dev-perl/Pango/Pango-1.227.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-perl/Pango/Pango-1.227.0.ebuild b/dev-perl/Pango/Pango-1.227.0.ebuild
new file mode 100644
index 000000000000..5bc5648e0e8d
--- /dev/null
+++ b/dev-perl/Pango/Pango-1.227.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=1.227
+VIRTUALX_REQUIRED=manual
+
+inherit perl-module virtualx
+
+DESCRIPTION="Layout and render international text"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test minimal"
+
+RDEPEND="
+ >=dev-perl/glib-perl-1.220.0
+ >=dev-perl/Cairo-1.0.0
+ >=x11-libs/pango-1.0.0
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.300.0
+ >=dev-perl/extutils-pkgconfig-1.30.0
+ test? (
+ virtual/perl-Test-Simple
+ !minimal? (
+ >=dev-perl/gtk2-perl-1.220.0
+ $VIRTUALX_DEPEND
+ )
+ )
+"
+
+src_prepare() {
+ perl-module_src_prepare
+ sed -i -e "s:exit 0:exit 1:g" "${S}"/Makefile.PL || die "sed failed"
+}
+src_install() {
+ local mydoc
+ mydoc=("NEWS")
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}
+src_test() {
+ virtx perl-module_src_test
+}