summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-21 07:47:50 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-21 23:23:08 +1300
commit0d4b497c81d4ed44fb66cc6adf795c9a03273744 (patch)
tree1d06106ad142c3017e45dec1bf0aed0689e40c8e /dev-perl/Panotools-Script/Panotools-Script-0.280.0-r2.ebuild
parentdev-perl/Data-FormValidator: empty rbump for nodyndeps (diff)
downloadgentoo-0d4b497c81d4ed44fb66cc6adf795c9a03273744.tar.gz
gentoo-0d4b497c81d4ed44fb66cc6adf795c9a03273744.tar.bz2
gentoo-0d4b497c81d4ed44fb66cc6adf795c9a03273744.zip
dev-perl/Panotools-Script: r1 bump for non-dyndeps
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Panotools-Script/Panotools-Script-0.280.0-r2.ebuild')
-rw-r--r--dev-perl/Panotools-Script/Panotools-Script-0.280.0-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Panotools-Script/Panotools-Script-0.280.0-r2.ebuild b/dev-perl/Panotools-Script/Panotools-Script-0.280.0-r2.ebuild
new file mode 100644
index 000000000000..e59dff2a7d98
--- /dev/null
+++ b/dev-perl/Panotools-Script/Panotools-Script-0.280.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=BPOSTLE
+MODULE_VERSION=0.28
+inherit eutils perl-module
+
+DESCRIPTION="A perl module for reading, writing, and manipulating hugin script files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND="dev-perl/URI
+ dev-perl/libwww-perl
+ >=dev-perl/Image-Size-2.900.0
+ >=media-libs/exiftool-6
+ gui? ( gnome-extra/zenity )"
+DEPEND=""
+
+SRC_TEST="do"
+
+src_install() {
+ perl-module_src_install
+ if use gui ; then
+ domenu "${S}"/desktop/*.desktop || die
+ else
+ rm "${D}"/usr/bin/*-gui || die
+ fi
+}
+
+pkg_postinst() {
+ einfo "Some of the scripts require 'nona', 'freepv', 'enblend', 'autotrace', and"
+ einfo "ImageMagick command-line tools which are available in the following"
+ einfo "packages: media-gfx/hugin, media-gfx/freepv, media-gfx/enblend,"
+ einfo "media-gfx/autotrace, and media-gfx/imagemagick."
+}