summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-24 13:21:05 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-24 13:22:49 +1300
commit504f447ff488f89ea556fd3a35d7a21216532a7d (patch)
tree265940364b272720c756f3dad077935626c7bab1 /dev-perl/Panotools-Script/Panotools-Script-0.280.0-r3.ebuild
parentgames-rpg/runescape-launcher: Regenerate Manifest (diff)
downloadgentoo-504f447ff488f89ea556fd3a35d7a21216532a7d.tar.gz
gentoo-504f447ff488f89ea556fd3a35d7a21216532a7d.tar.bz2
gentoo-504f447ff488f89ea556fd3a35d7a21216532a7d.zip
dev-perl/Panotools-Script: Fix test failures re bug #623084
- EAPI6 - Fix test failures Bug: https://bugs.gentoo.org/623084 Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Panotools-Script/Panotools-Script-0.280.0-r3.ebuild')
-rw-r--r--dev-perl/Panotools-Script/Panotools-Script-0.280.0-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Panotools-Script/Panotools-Script-0.280.0-r3.ebuild b/dev-perl/Panotools-Script/Panotools-Script-0.280.0-r3.ebuild
new file mode 100644
index 000000000000..c04a544f9aed
--- /dev/null
+++ b/dev-perl/Panotools-Script/Panotools-Script-0.280.0-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=BPOSTLE
+DIST_VERSION=0.28
+inherit eutils perl-module
+
+DESCRIPTION="A perl module for reading, writing, and manipulating hugin script files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND="dev-perl/URI
+ dev-perl/libwww-perl
+ >=dev-perl/Image-Size-2.900.0
+ >=media-libs/exiftool-6
+ gui? ( gnome-extra/zenity )"
+DEPEND=""
+PATCHES=( "${FILESDIR}/${PN}-0.28-curly-bracket.patch" )
+
+src_install() {
+ perl-module_src_install
+ if use gui ; then
+ domenu "${S}"/desktop/*.desktop || die
+ else
+ rm "${D}"/usr/bin/*-gui || die
+ fi
+}
+
+pkg_postinst() {
+ einfo "Some of the scripts require 'nona', 'freepv', 'enblend', 'autotrace', and"
+ einfo "ImageMagick command-line tools which are available in the following"
+ einfo "packages: media-gfx/hugin, media-gfx/freepv, media-gfx/enblend,"
+ einfo "media-gfx/autotrace, and media-gfx/imagemagick."
+}