summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-23 23:51:26 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-23 23:57:56 +0200
commit776e6b513d631987393df477907f22fc8819ade6 (patch)
treec87a857c3ca4864a17af246e7480427c2b1cc4d8 /dev-perl/Parallel-Prefork/Parallel-Prefork-0.180.0-r1.ebuild
parentdev-perl/Parallel-Iterator: EAPI=8 bump (diff)
downloadgentoo-776e6b513d631987393df477907f22fc8819ade6.tar.gz
gentoo-776e6b513d631987393df477907f22fc8819ade6.tar.bz2
gentoo-776e6b513d631987393df477907f22fc8819ade6.zip
dev-perl/Parallel-Prefork: EAPI=8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Parallel-Prefork/Parallel-Prefork-0.180.0-r1.ebuild')
-rw-r--r--dev-perl/Parallel-Prefork/Parallel-Prefork-0.180.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Parallel-Prefork/Parallel-Prefork-0.180.0-r1.ebuild b/dev-perl/Parallel-Prefork/Parallel-Prefork-0.180.0-r1.ebuild
new file mode 100644
index 000000000000..b254a74d0a9f
--- /dev/null
+++ b/dev-perl/Parallel-Prefork/Parallel-Prefork-0.180.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=KAZUHO
+DIST_VERSION=0.18
+inherit perl-module
+
+DESCRIPTION="A simple prefork server framework"
+
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="
+ >=dev-perl/Class-Accessor-Lite-0.40.0
+ dev-perl/List-MoreUtils
+ >=dev-perl/Proc-Wait3-0.30.0
+ dev-perl/Scope-Guard
+ dev-perl/Signal-Mask
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ dev-perl/Test-Requires
+ dev-perl/Test-SharedFork
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-RT113449.patch" )
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}