summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Parse-RecDescent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Parse-RecDescent')
-rw-r--r--dev-perl/Parse-RecDescent/Manifest1
-rw-r--r--dev-perl/Parse-RecDescent/Parse-RecDescent-1.967.9-r1.ebuild33
-rw-r--r--dev-perl/Parse-RecDescent/metadata.xml26
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-perl/Parse-RecDescent/Manifest b/dev-perl/Parse-RecDescent/Manifest
new file mode 100644
index 000000000000..cc647c95c52d
--- /dev/null
+++ b/dev-perl/Parse-RecDescent/Manifest
@@ -0,0 +1 @@
+DIST Parse-RecDescent-1.967009.tar.gz 170858 SHA256 e1000f0b82256269fb8daa43aab166a7832fc18b4689af7c8d6d1a49fe75c687 SHA512 8423f4c61770ec77b67c656755dd952fb01b739405fe0586d502d9698f8b18e401ca7f40e7e88208af4a15c0f7d45c4ecf5f20032014cf650351763516515cae WHIRLPOOL 91af978877642f54bf4e8464343a79892242a49859df78c3f11962ca2e09eafcc69cbd2e935a5220e1552fa90907d0b02a866d4cfa3b4339ac16afb74a95d45e
diff --git a/dev-perl/Parse-RecDescent/Parse-RecDescent-1.967.9-r1.ebuild b/dev-perl/Parse-RecDescent/Parse-RecDescent-1.967.9-r1.ebuild
new file mode 100644
index 000000000000..808cafbb16f5
--- /dev/null
+++ b/dev-perl/Parse-RecDescent/Parse-RecDescent-1.967.9-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JTBRAUN
+MODULE_VERSION=1.967009
+inherit perl-module
+
+DESCRIPTION="Parse::RecDescent - generate recursive-descent parsers"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Text-Balanced-1.950.0
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Warn
+ )
+"
+
+SRC_TEST="do"
+
+src_install() {
+ perl-module_src_install
+ dohtml -r tutorial || die
+}
diff --git a/dev-perl/Parse-RecDescent/metadata.xml b/dev-perl/Parse-RecDescent/metadata.xml
new file mode 100644
index 000000000000..d48552cf87e0
--- /dev/null
+++ b/dev-perl/Parse-RecDescent/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Parse-RecDescent</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Action</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::ColCounter</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Directive</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Error</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Expectation</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::InterpLit</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::LineCounter</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Literal</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::OffsetCounter</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Operator</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Production</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Repetition</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Result</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Rule</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Subrule</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::Token</remote-id>
+ <remote-id type="cpan-module">Parse::RecDescent::UncondReject</remote-id>
+ </upstream>
+</pkgmetadata>