summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-24 01:13:46 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-24 01:14:05 +1300
commited1aeb9fd035febfa281ae36db08708cb253c5ac (patch)
treeaf241d7a35f91cdbcfaabad6705f679fced43357 /dev-perl/Path-IsDev/Path-IsDev-1.1.3.ebuild
parentx11-themes/gtk-engines-adwaita: explicitly inherit ltprune for prune_libtool_... (diff)
downloadgentoo-ed1aeb9fd035febfa281ae36db08708cb253c5ac.tar.gz
gentoo-ed1aeb9fd035febfa281ae36db08708cb253c5ac.tar.bz2
gentoo-ed1aeb9fd035febfa281ae36db08708cb253c5ac.zip
dev-perl/Path-IsDev: Bump to version 1.1.3
Upstream: - Fix issues with '.' in @INC in tests - Tests much faster Bug: https://bugs.gentoo.org/613616 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Path-IsDev/Path-IsDev-1.1.3.ebuild')
-rw-r--r--dev-perl/Path-IsDev/Path-IsDev-1.1.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Path-IsDev/Path-IsDev-1.1.3.ebuild b/dev-perl/Path-IsDev/Path-IsDev-1.1.3.ebuild
new file mode 100644
index 000000000000..160e9c561bc9
--- /dev/null
+++ b/dev-perl/Path-IsDev/Path-IsDev-1.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KENTNL
+DIST_VERSION=1.001003
+inherit perl-module
+
+DESCRIPTION="Determine if a given Path resembles a development source tree"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Class-Tiny-0.10.0
+ dev-perl/File-HomeDir
+ dev-perl/Module-Runtime
+ >=dev-perl/Path-Tiny-0.4.0
+ dev-perl/Role-Tiny
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Sub-Exporter
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ !minimal? ( >=virtual/perl-ExtUtils-MakeMaker-7.0.0 )
+ test? (
+ !minimal? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ >=virtual/perl-Test-Simple-0.990.0
+ )
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/Test-Fatal
+ virtual/perl-Test-Simple
+ )
+"