summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-17 03:51:52 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-17 04:55:46 +1200
commit0df6092e78bc62bd7096674a7f15e508a8e0383d (patch)
tree880bb2072858802f58e9dd25087a02abef629ba2 /dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild
parentdev-perl/Test-Filename: Add w/ v=0.30.0-r2 (diff)
downloadgentoo-0df6092e78bc62bd7096674a7f15e508a8e0383d.tar.gz
gentoo-0df6092e78bc62bd7096674a7f15e508a8e0383d.tar.bz2
gentoo-0df6092e78bc62bd7096674a7f15e508a8e0383d.zip
dev-perl/Path-Iterator-Rule: Add w/ v=1.14.0
Required by: - dev-perl/Dist-Zilla-Plugin-CheckExtraTests 0.29.0 - via app-admin/rex-9999 Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild')
-rw-r--r--dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild b/dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild
new file mode 100644
index 000000000000..3a8ae7121aba
--- /dev/null
+++ b/dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.14.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=1.014
+inherit perl-module
+
+DESCRIPTION="Iterative, recursive file finder"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Spec
+ >=dev-perl/Number-Compare-0.20.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Text-Glob
+ dev-perl/Try-Tiny
+ virtual/perl-if
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ virtual/perl-Exporter
+ virtual/perl-File-Temp
+ dev-perl/File-pushd
+ dev-perl/Path-Tiny
+ dev-perl/Test-Deep
+ >=dev-perl/Test-Filename-0.30.0
+ >=virtual/perl-Test-Simple-0.920.0
+ virtual/perl-parent
+ )
+"