summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-19 18:05:22 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-19 23:41:50 +0100
commitf17d93fe983f051b78b367b7b7089aaa61ea7b19 (patch)
tree447650eee182e2641d1dcdb2b1ced118a6dda7bd /dev-perl/Perl-Tags/Perl-Tags-0.320.0.ebuild
parentdev-perl/PerlIO-gzip: Bump to version 0.190.0 (diff)
downloadgentoo-f17d93fe983f051b78b367b7b7089aaa61ea7b19.tar.gz
gentoo-f17d93fe983f051b78b367b7b7089aaa61ea7b19.tar.bz2
gentoo-f17d93fe983f051b78b367b7b7089aaa61ea7b19.zip
dev-perl/Perl-Tags: Bumped to version 0.320.0
- EAPI6 - Fix vim failure test https://rt.cpan.org/Ticket/Display.html?id=105899 - Fix installation of README.pod https://rt.cpan.org/Ticket/Display.html?id=113166 - Make more dependencies optional Upstream: - Added fatpacked script - Improved defaults - Add Moose scraping tagger - Add PPI + Native hybrid tagger - Added -files option - Option -no-vars fixed - Tests use $^X instead of `perl` Keywords: Dropped: amd64-linux ppc-macos sparc-solaris x86-linux x86-macos Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Perl-Tags/Perl-Tags-0.320.0.ebuild')
-rw-r--r--dev-perl/Perl-Tags/Perl-Tags-0.320.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Perl-Tags/Perl-Tags-0.320.0.ebuild b/dev-perl/Perl-Tags/Perl-Tags-0.320.0.ebuild
new file mode 100644
index 000000000000..b568528b20d0
--- /dev/null
+++ b/dev-perl/Perl-Tags/Perl-Tags-0.320.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=OSFAMERON
+DIST_VERSION=0.32
+inherit perl-module
+
+DESCRIPTION="Generate (possibly exuberant) Ctags style tags for Perl sourcecode"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test minimal"
+
+PATCHES=(
+ "${FILESDIR}/vim_noplugin.patch" # https://rt.cpan.org/Ticket/Display.html?id=105899
+)
+PERL_RM_FILES=(
+ "README.pod" # https://rt.cpan.org/Ticket/Display.html?id=113166
+)
+RDEPEND="
+ dev-perl/File-Find-Rule
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/Module-Locate
+ dev-perl/Path-Tiny
+ virtual/perl-parent
+ !minimal? (
+ dev-perl/PPI
+ )
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? (
+ dev-perl/Capture-Tiny
+ dev-perl/Test-Exception
+ dev-perl/Test-LongString
+ >=virtual/perl-Test-Simple-0.420.0
+ !minimal? (
+ app-editors/vim[perl]
+ )
+ )
+"