summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-27 19:18:19 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-27 21:09:55 +1300
commit94f86c1810ded0474962d53abb333394f28884b7 (patch)
treeec3ab8d3d53100d02542ec9d2c40ea31244d3b94 /dev-perl/Perl-Tags/files
parentdev-perl/Perl-Critic-Dynamic: EAPI6 + tests (diff)
downloadgentoo-94f86c1810ded0474962d53abb333394f28884b7.tar.gz
gentoo-94f86c1810ded0474962d53abb333394f28884b7.tar.bz2
gentoo-94f86c1810ded0474962d53abb333394f28884b7.zip
dev-perl/Perl-Tags: Restore tests
- Migrate Perl 5.26 sed to a patch - Disable Vim tests without opt-in Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Perl-Tags/files')
-rw-r--r--dev-perl/Perl-Tags/files/Perl-Tags-0.32-no-dot-inc.patch25
-rw-r--r--dev-perl/Perl-Tags/files/Perl-Tags-0.32-no-vim-tests.patch29
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-perl/Perl-Tags/files/Perl-Tags-0.32-no-dot-inc.patch b/dev-perl/Perl-Tags/files/Perl-Tags-0.32-no-dot-inc.patch
new file mode 100644
index 000000000000..06c82a1878e8
--- /dev/null
+++ b/dev-perl/Perl-Tags/files/Perl-Tags-0.32-no-dot-inc.patch
@@ -0,0 +1,25 @@
+From e2124dd7f4a0a43082248bdcfb26aa0c2832d1a2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
+Date: Mon, 3 Jul 2017 03:15:36 +1200
+Subject: Fix build on Perl 5.26
+
+Bug: https://bugs.gentoo.org/623068
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index ed5c5f7..0a01281 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,6 +1,6 @@
+ use strict;
+ use warnings;
+-use inc::Module::Install;
++use lib q[.]; use inc::Module::Install;
+
+ name 'Perl-Tags';
+ all_from 'lib/Perl/Tags.pm';
+--
+2.15.1
+
diff --git a/dev-perl/Perl-Tags/files/Perl-Tags-0.32-no-vim-tests.patch b/dev-perl/Perl-Tags/files/Perl-Tags-0.32-no-vim-tests.patch
new file mode 100644
index 000000000000..a9f1c3f50b13
--- /dev/null
+++ b/dev-perl/Perl-Tags/files/Perl-Tags-0.32-no-vim-tests.patch
@@ -0,0 +1,29 @@
+From 8e0f11c8805c8f7b1dc6f03b864cf782ea8607a5 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 27 Dec 2017 18:59:04 +1300
+Subject: Fence off VIM tests without explicit activation
+
+---
+ t/05_vim.t | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/t/05_vim.t b/t/05_vim.t
+index 8b3c682..becf93a 100644
+--- a/t/05_vim.t
++++ b/t/05_vim.t
+@@ -1,4 +1,12 @@
+ use strict; use warnings;
++
++BEGIN {
++ if ( not $ENV{VIM_TESTS} ) {
++ print "1..0 # SKIP VIM_TESTS not set";
++ exit;
++ }
++}
++
+ use Data::Dumper;
+
+ use Test::More tests=>1;
+--
+2.15.1
+