summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Proc-ProcessTable
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Proc-ProcessTable')
-rw-r--r--dev-perl/Proc-ProcessTable/Manifest1
-rw-r--r--dev-perl/Proc-ProcessTable/Proc-ProcessTable-0.480.0.ebuild22
-rw-r--r--dev-perl/Proc-ProcessTable/files/0.45-fix-format-errors.patch30
-rw-r--r--dev-perl/Proc-ProcessTable/files/0.45-pthread.patch15
-rw-r--r--dev-perl/Proc-ProcessTable/files/amd64_canonicalize_file_name_definition.patch13
-rw-r--r--dev-perl/Proc-ProcessTable/metadata.xml12
6 files changed, 93 insertions, 0 deletions
diff --git a/dev-perl/Proc-ProcessTable/Manifest b/dev-perl/Proc-ProcessTable/Manifest
new file mode 100644
index 000000000000..c7a407755b3e
--- /dev/null
+++ b/dev-perl/Proc-ProcessTable/Manifest
@@ -0,0 +1 @@
+DIST Proc-ProcessTable-0.48.tar.gz 70706 SHA256 4175789ee35abeb99071b41b989ff8c52d119058a12502975d34431c77e8340c SHA512 7ef6cd3936f3480ff3e59ea29b610ba77a078a298730053ff093956a4f3c2a4e0b61937e0aee1280dd439b0e5d41ba703ab81a77690d2f026e22b8df80be6808 WHIRLPOOL 3c8a7ab2d43d981f84a4e545260b5478c636eb033635717da1bee3582a52533ef5eee145323d47c534c7928c36d1a9d8acf288d5c7f5227e372e2c12b1bc3f72
diff --git a/dev-perl/Proc-ProcessTable/Proc-ProcessTable-0.480.0.ebuild b/dev-perl/Proc-ProcessTable/Proc-ProcessTable-0.480.0.ebuild
new file mode 100644
index 000000000000..8b5a028402c6
--- /dev/null
+++ b/dev-perl/Proc-ProcessTable/Proc-ProcessTable-0.480.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JWB
+MODULE_VERSION=0.48
+inherit perl-module
+
+DESCRIPTION="Unix process table information"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+SRC_TEST="do"
+PATCHES=(
+ "${FILESDIR}/amd64_canonicalize_file_name_definition.patch"
+ "${FILESDIR}/0.45-pthread.patch"
+ "${FILESDIR}/0.45-fix-format-errors.patch"
+)
diff --git a/dev-perl/Proc-ProcessTable/files/0.45-fix-format-errors.patch b/dev-perl/Proc-ProcessTable/files/0.45-fix-format-errors.patch
new file mode 100644
index 000000000000..c7bbec993446
--- /dev/null
+++ b/dev-perl/Proc-ProcessTable/files/0.45-fix-format-errors.patch
@@ -0,0 +1,30 @@
+https://rt.cpan.org/Public/Bug/Display.html?id=48445
+--- Proc-ProcessTable-0.45/os/Linux.c
++++ Proc-ProcessTable-0.45/os/Linux.c
+@@ -397,7 +397,7 @@
+
+ /* copy the path onto our obstack, set the value (somewhere in pts)
+ * and free the results of canonicalize_file_name */
+- obstack_printf(mem_pool, link);
++ obstack_printf(mem_pool, "%s", link);
+ obstack_1grow(mem_pool, '\0');
+
+ *ptr = (char *) obstack_finish(mem_pool);
+@@ -618,7 +618,7 @@
+ bzero(prs, sizeof(struct procstat));
+
+ /* intilize the format string */
+- obstack_printf(&mem_pool, get_string(STR_DEFAULT_FORMAT));
++ obstack_printf(&mem_pool, "%s", get_string(STR_DEFAULT_FORMAT));
+ obstack_1grow(&mem_pool, '\0');
+ format_str = (char *) obstack_finish(&mem_pool);
+
+--- Proc-ProcessTable-0.45/ProcessTable.xs
++++ Proc-ProcessTable-0.45/ProcessTable.xs
+@@ -388,5 +388,5 @@
+ char* error;
+
+ if( (error = OS_initialize()) != NULL ){
+- croak(error);
++ croak("%s", error);
+ }
diff --git a/dev-perl/Proc-ProcessTable/files/0.45-pthread.patch b/dev-perl/Proc-ProcessTable/files/0.45-pthread.patch
new file mode 100644
index 000000000000..537e2926c4d7
--- /dev/null
+++ b/dev-perl/Proc-ProcessTable/files/0.45-pthread.patch
@@ -0,0 +1,15 @@
+https://rt.cpan.org/Public/Bug/Display.html?id=46861
+--- Proc-ProcessTable-0.45/hints/linux.pl
++++ Proc-ProcessTable-0.45/hints/linux.pl
+@@ -1 +1,11 @@
++# We might have a non-threading perl, which doesn't add this
++# necessary link option.
++use Config;
++my $thread_lib = "-lpthread";
++
++if( $Config{libs} !~ /$thread_lib/ ) {
++ $self->{LIBS} ||= [];
++ push @{ $self->{LIBS} }, $thread_lib;
++}
++
+ symlink "os/Linux.c", "OS.c" || die "Could not link os/Linux.c to os/OS.c\n";
diff --git a/dev-perl/Proc-ProcessTable/files/amd64_canonicalize_file_name_definition.patch b/dev-perl/Proc-ProcessTable/files/amd64_canonicalize_file_name_definition.patch
new file mode 100644
index 000000000000..d454b1ad21cb
--- /dev/null
+++ b/dev-perl/Proc-ProcessTable/files/amd64_canonicalize_file_name_definition.patch
@@ -0,0 +1,13 @@
+Index: Proc-ProcessTable-0.45/os/Linux.c
+===================================================================
+--- Proc-ProcessTable-0.45.orig/os/Linux.c
++++ Proc-ProcessTable-0.45/os/Linux.c
+@@ -33,7 +33,7 @@ static unsigned system_hertz;
+
+ static bool init_failed = false;
+
+-
++char *canonicalize_file_name (const char *path);
+ /* get_string()
+ *
+ * Access strings in read only section
diff --git a/dev-perl/Proc-ProcessTable/metadata.xml b/dev-perl/Proc-ProcessTable/metadata.xml
new file mode 100644
index 000000000000..32744df0d6f2
--- /dev/null
+++ b/dev-perl/Proc-ProcessTable/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Proc-ProcessTable</remote-id>
+ <remote-id type="cpan-module">Proc::Killall</remote-id>
+ <remote-id type="cpan-module">Proc::Killfam</remote-id>
+ <remote-id type="cpan-module">Proc::ProcessTable</remote-id>
+ <remote-id type="cpan-module">Proc::ProcessTable::Process</remote-id>
+ </upstream>
+</pkgmetadata>