summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-01-04 02:01:22 +1300
committerKent Fredric <kentnl@gentoo.org>2018-01-04 02:40:43 +1300
commitc4f82644e0cd24b17799458359a2962c30562260 (patch)
tree6db358b7c89a5cce5739418c6608bc1353be8f86 /dev-perl/RRD-Simple/RRD-Simple-1.440.0-r2.ebuild
parentnet-vpn/tor: 0.3.1.9-r1 stable on ppc and ppc64, bug #642524 (diff)
downloadgentoo-c4f82644e0cd24b17799458359a2962c30562260.tar.gz
gentoo-c4f82644e0cd24b17799458359a2962c30562260.tar.bz2
gentoo-c4f82644e0cd24b17799458359a2962c30562260.zip
dev-perl/RRD-Simple: EAPI6 + tests
- EAPI6ify - Enable tests - Add USE=examples - Cleanup useless deps - Cleanup useless tests - Hard disable phone-home logic - Fix test failures without '.' in @INC - Patch tests for various changes in Perl Inf/Nan handling - Patch tests for various changes in RRDtool - Patch tests for parallel testing Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/RRD-Simple/RRD-Simple-1.440.0-r2.ebuild')
-rw-r--r--dev-perl/RRD-Simple/RRD-Simple-1.440.0-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/RRD-Simple/RRD-Simple-1.440.0-r2.ebuild b/dev-perl/RRD-Simple/RRD-Simple-1.440.0-r2.ebuild
new file mode 100644
index 000000000000..d8f2032c76e2
--- /dev/null
+++ b/dev-perl/RRD-Simple/RRD-Simple-1.440.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=NICOLAW
+DIST_VERSION=1.44
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Simple interface to create and store data in RRD files"
+SRC_URI+=" https://dev.gentoo.org/~kentnl/distfiles/${PN}-${DIST_VERSION}-patches-1.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ net-analyzer/rrdtool[perl]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ >=dev-perl/Test-Deep-0.93.0
+ )
+"
+PATCHES=( "${WORKDIR}/patches" )