summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-08 15:53:14 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-08 16:45:37 +0200
commitaa8d4aa157592df4fef0cc08776f1266f5ada214 (patch)
tree177a5d720f8020c224cfd49c71b63dbf5d4306f0 /dev-perl/SOAP-Lite
parentdev-perl/Snowball-Swedish: EAPI=8 bump (diff)
downloadgentoo-aa8d4aa157592df4fef0cc08776f1266f5ada214.tar.gz
gentoo-aa8d4aa157592df4fef0cc08776f1266f5ada214.tar.bz2
gentoo-aa8d4aa157592df4fef0cc08776f1266f5ada214.zip
dev-perl/SOAP-Lite: Version bump 1.27
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/SOAP-Lite')
-rw-r--r--dev-perl/SOAP-Lite/Manifest1
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-1.270.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-perl/SOAP-Lite/Manifest b/dev-perl/SOAP-Lite/Manifest
index 3ad8bd19c4fb..bef95778b348 100644
--- a/dev-perl/SOAP-Lite/Manifest
+++ b/dev-perl/SOAP-Lite/Manifest
@@ -1 +1,2 @@
DIST SOAP-Lite-1.26.tar.gz 272187 BLAKE2B ec4519c258b2822da74c41e20dc2c0ea3242a7d1936c2e8bf637f6cfa53fc721e4864f0ca0332986f5a1c912babe522c1b409d48dc0c433abd3f85c4aa207cb6 SHA512 b09e320cecbb4859f49dcb144a446af878219f6ba3d2f7999f8656f40989d3ead0707960f561d17a9f800706fcb53020327f9c85313f6dcca34f9699a4c74143
+DIST SOAP-Lite-1.27.tar.gz 271466 BLAKE2B 045edbe5d09a935af6b73df20d3af0d646cfa726c5fc0e050c0cfb557903c2ccd86e40d506114dad7c4c295c934a3a95250fdf9e0c558bf0f948e2ea0af67840 SHA512 38ecd0eb2af3ca415cb82e98a68aabd2cd3eca1625a7850723ae3c9f03f32f1ce3141d2a9382b80e250a88e3007eb7a0aa75f47c7e593c2c2025a29c8c32ee3b
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-1.270.0.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-1.270.0.ebuild
new file mode 100644
index 000000000000..fd408bbedf36
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-1.270.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=PHRED
+DIST_VERSION=1.27
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Lightweight interface to the SOAP protocol both on client and server side"
+
+IUSE="ssl test xmpp"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+myconf="${myconf} --noprompt"
+
+RDEPEND="
+ dev-perl/Class-Inspector
+ >=dev-perl/IO-SessionData-1.30.0
+ dev-perl/libwww-perl
+ virtual/perl-MIME-Base64
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Task-Weaken
+ dev-perl/URI
+ >=dev-perl/XML-Parser-2.230.0
+ dev-perl/MIME-tools
+ ssl? (
+ dev-perl/IO-Socket-SSL
+ dev-perl/LWP-Protocol-https
+ dev-perl/Crypt-SSLeay
+ )
+ xmpp? ( dev-perl/Net-Jabber )
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ dev-perl/Test-Warn
+ >=dev-perl/XML-Parser-Lite-0.715.0
+ )
+"
+
+PERL_RM_FILES=(
+ "t/author-pod-syntax.t"
+ "t/release-kwalitee.t"
+)
+
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}