summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-10 20:20:00 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-10 20:23:58 +0200
commit3752f98e411886c81993913fb7eaba9c9666a354 (patch)
tree6de64093732bb02c4660bfa152f6ecc834d5eb48 /dev-perl/SVG
parentdev-perl/SUPER: EAPI=8 bump (diff)
downloadgentoo-3752f98e411886c81993913fb7eaba9c9666a354.tar.gz
gentoo-3752f98e411886c81993913fb7eaba9c9666a354.tar.bz2
gentoo-3752f98e411886c81993913fb7eaba9c9666a354.zip
dev-perl/SVG: Version bump 2.86
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/SVG')
-rw-r--r--dev-perl/SVG/Manifest1
-rw-r--r--dev-perl/SVG/SVG-2.860.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/SVG/Manifest b/dev-perl/SVG/Manifest
index 7f8db47bdd69..22d2ed93c583 100644
--- a/dev-perl/SVG/Manifest
+++ b/dev-perl/SVG/Manifest
@@ -1 +1,2 @@
DIST SVG-2.82.tar.gz 53717 BLAKE2B eb09b912cc719a53b7aa990ca0d56213c6c3e46f36ff7a0e32e3e643d3a012541f5bdeb4077b3cdb879c19ceec7d7bca9a38d42b78e6d18cdde0a2358ba61f28 SHA512 4241cfdc05758d90b7c2fd8a0fd2df1a8a95bad6859a6e30eb2f05a6c6e15f37ab9739304e956929f48b20a41c2b309fc97854440a4a1350a4badd515c7041a5
+DIST SVG-2.86.tar.gz 57375 BLAKE2B bb9ae8664fab28d3fcc8886dd636ba6944f10a43d4d6811a97a64fba9ed1a3cb0fb8057ead1233654384faa24931817c2f8b7f41358d9674977ecd091b4f2ca0 SHA512 d8f66c3103cf7fabe0902f86c768e04c757b2c95c5b3291a273e3d3da0201042d6cd70f3a5c005fc0e8b3a6c075c212b9d0bc265f80e210fb8ecfca8178473d0
diff --git a/dev-perl/SVG/SVG-2.860.0.ebuild b/dev-perl/SVG/SVG-2.860.0.ebuild
new file mode 100644
index 000000000000..5b3cccea394f
--- /dev/null
+++ b/dev-perl/SVG/SVG-2.860.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MANWAR
+DIST_VERSION=2.86
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Perl extension for generating Scalable Vector Graphics (SVG) documents"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ virtual/perl-parent
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+src_test() {
+ perl_rm_files t/96-perl-critic.t t/98-tidyall.t \
+ t/99_test_pod_coverage.t \
+ t/meta-json.t \
+ t/meta-yml.t
+ perl-module_src_test
+}