summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-08 20:28:41 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-08 20:29:27 +1200
commit481bf47e6879750fc517c28bfa07abb8de355301 (patch)
tree5b129d970b8c83e87c59c7f3fcc6c3cb60dfb5dd /dev-perl/Statistics-Basic/Statistics-Basic-1.661.100.ebuild
parentsys-kernel/vanilla-sources: Automated version bump to {5.4.31,5.5.16,5.6.3} -... (diff)
downloadgentoo-481bf47e6879750fc517c28bfa07abb8de355301.tar.gz
gentoo-481bf47e6879750fc517c28bfa07abb8de355301.tar.bz2
gentoo-481bf47e6879750fc517c28bfa07abb8de355301.zip
dev-perl/Statistics-Basic: Add w/ version 1.661.100
Required by sci-visualization/circos-0.69.9 Original submitted ebuild reworked from scratch with lots of various fixes. ( perl 5.26-- ) See: https://github.com/gentoo/gentoo/pull/13615 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Statistics-Basic/Statistics-Basic-1.661.100.ebuild')
-rw-r--r--dev-perl/Statistics-Basic/Statistics-Basic-1.661.100.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Statistics-Basic/Statistics-Basic-1.661.100.ebuild b/dev-perl/Statistics-Basic/Statistics-Basic-1.661.100.ebuild
new file mode 100644
index 000000000000..86e11b2c710e
--- /dev/null
+++ b/dev-perl/Statistics-Basic/Statistics-Basic-1.661.100.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=JETTERO
+DIST_VERSION=1.6611
+inherit perl-module
+
+DESCRIPTION="A collection of very basic statistics modules"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Number-Format-1.420.0
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-${DIST_VERSION}-no-dot-inc.patch"
+)
+PERL_RM_FILES=(
+ "t/pod_coverage.t"
+ "t/pod.t"
+ "t/critic.t"
+)