summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-11 01:35:41 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-12 00:54:10 +0200
commit3eccb21e08b496a3dccffbb7c35c257c240ce3d0 (patch)
tree70975dad086b9a5a595ff599bc755d5845971947 /dev-perl/Statistics-Descriptive
parentdev-perl/Starlet: Bump to version 0.29.0 (diff)
downloadgentoo-3eccb21e08b496a3dccffbb7c35c257c240ce3d0.tar.gz
gentoo-3eccb21e08b496a3dccffbb7c35c257c240ce3d0.tar.bz2
gentoo-3eccb21e08b496a3dccffbb7c35c257c240ce3d0.zip
dev-perl/Statistics-Descriptive: Bump to version 3.61.200
- EAPI6 - Add USE="examples" - Pruned useless tests Upstream: - add median_absolute_derivation method - skewness calculations sped up - Many Packaging and documentation fixes. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Statistics-Descriptive')
-rw-r--r--dev-perl/Statistics-Descriptive/Manifest1
-rw-r--r--dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.61.200.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Statistics-Descriptive/Manifest b/dev-perl/Statistics-Descriptive/Manifest
index fc020b0db65a..59d6be119c23 100644
--- a/dev-perl/Statistics-Descriptive/Manifest
+++ b/dev-perl/Statistics-Descriptive/Manifest
@@ -1 +1,2 @@
DIST Statistics-Descriptive-3.0603.tar.gz 34511 SHA256 2432f3131d4f4000586b2d2d58c2fe914c979efbcc3357bc57e8f0360c2e9387 SHA512 29b740e543fa6d2804a2bd69aeac2f24edad4c36ce6fabfb2b35f8bdac436bb9372014084d4a59b0790e5f2391ff0483c1b3d11af4423303727142102f3153ba WHIRLPOOL d654fa9352f93b3b40e2ed2baec01efe4465426df36db1c06c7aac14d9a22b284f6518fc31d2fd880ed5b8fa49a63f76310244c2929f22061ac08e14235077ed
+DIST Statistics-Descriptive-3.0612.tar.gz 45929 SHA256 772413148e5e00efb32f277c4254aa78b9112490a896208dcd0025813afdbf7a SHA512 1157c0259a376f44363861c515ef56a25cf5a496d67faea546e225751d39c3529f9aa7d1bd021e2e399d5e884e7f5372df67249fe4f5607a6bdd806235503d46 WHIRLPOOL 55ca8bc072c4a652f840afbf57ce1d7232a127a43688cfdcae029db3247cb6638c7d2c9fa766de188fcba41e5b0c9bf1de5cdb2391b5344e17cd0e1cbe586122
diff --git a/dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.61.200.ebuild b/dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.61.200.ebuild
new file mode 100644
index 000000000000..17709c9dbf29
--- /dev/null
+++ b/dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.61.200.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=3.0612
+inherit perl-module
+
+DESCRIPTION="Module of basic descriptive statistical functions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test examples"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/List-MoreUtils
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.0
+ test? ( virtual/perl-Test-Simple )
+"
+mydoc="UserSurvey.txt"
+
+src_test() {
+ perl_rm_files "t/pod-coverage.t" "t/pod.t" "t/cpan-changes.t" "t/style-trailing-space.t"
+ perl-module_src_test
+}
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples/
+ dodoc -r examples
+ fi
+}