summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-12-11 03:22:06 +1300
committerKent Fredric <kentnl@gentoo.org>2016-12-11 03:25:29 +1300
commita3b6adddadedb116eff1c3d82fba306e8d203b7c (patch)
treed2958a32c272153eb33c80a280b1065ade4550c3 /dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild
parentmedia-libs/jasper: Install docs using relative path (diff)
downloadgentoo-a3b6adddadedb116eff1c3d82fba306e8d203b7c.tar.gz
gentoo-a3b6adddadedb116eff1c3d82fba306e8d203b7c.tar.bz2
gentoo-a3b6adddadedb116eff1c3d82fba306e8d203b7c.zip
dev-perl/Sub-Quote: Add w/ version 2.3.1
This has been teased out of Moo Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild')
-rw-r--r--dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild b/dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild
new file mode 100644
index 000000000000..e3a9ac5b246d
--- /dev/null
+++ b/dev-perl/Sub-Quote/Sub-Quote-2.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.003001
+inherit perl-module
+
+DESCRIPTION="efficient generation of subroutines via string eval"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ !<dev-perl/Moo-2.3.0
+ !minimal? (
+ >=dev-perl/Sub-Name-0.80.0
+ )
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"