summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-23 14:28:05 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-23 14:28:25 +1300
commit14da992b43ef6bcdddb9ecdb63c74820563fd647 (patch)
treebb30cf6ba133ebe1fcda6d6c9e8ce25cddbe4643 /dev-perl/Sys-Virt/Sys-Virt-3.1.0.ebuild
parentmedia-libs/grilo: remove old (diff)
downloadgentoo-14da992b43ef6bcdddb9ecdb63c74820563fd647.tar.gz
gentoo-14da992b43ef6bcdddb9ecdb63c74820563fd647.tar.bz2
gentoo-14da992b43ef6bcdddb9ecdb63c74820563fd647.zip
dev-perl/Sys-Virt: Bump to version 3.1.0
Upstream: - Add constants VIR_CONNECT_LIST_STORAGE_POOLS_VSTORAGE, VIR_CONNECT_LIST_NODE_DEVICES_CAP_DRM, PERF_PARAM_BRANCH_MISSES, PERF_PARAM_BUS_CYCLES, PERF_PARAM_STALLED_CYCLES_FRONTEND, PERF_PARAM_STALLED_CYCLES_BACKEND, PERF_PARAM_REF_CPU_CYCLES - Add virDomainSetVcpu API - Add group_name for block iotune - Add new branch instructions for perf event - Add virStorageVolGetInfoFlags + Constants - Add domain metadata change event - Add secret event APIs Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Sys-Virt/Sys-Virt-3.1.0.ebuild')
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-3.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Sys-Virt/Sys-Virt-3.1.0.ebuild b/dev-perl/Sys-Virt/Sys-Virt-3.1.0.ebuild
new file mode 100644
index 000000000000..6755aa7e83b8
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DANBERR
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=app-emulation/libvirt-${PV}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}
+
+src_test() {
+ perl_rm_files "t/010-pod-coverage.t" "t/005-pod.t" "t/015-changes.t"
+ perl-module_src_test
+}