summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-09 10:59:59 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-09 11:11:30 +1200
commit95213ae276d8605f8fa87e79ce4582694e64803f (patch)
treea55fff090d46482f21001d6a87b37a0f595300e2 /dev-perl/Sys-Virt/Sys-Virt-3.3.0.ebuild
parentdev-perl/Sys-Virt: Patch for '.' in @INC re bug #613584 (diff)
downloadgentoo-95213ae276d8605f8fa87e79ce4582694e64803f.tar.gz
gentoo-95213ae276d8605f8fa87e79ce4582694e64803f.tar.bz2
gentoo-95213ae276d8605f8fa87e79ce4582694e64803f.zip
dev-perl/Sys-Virt: Bump to version 3.3.0
Upstream: - New constants: PERF_PARAM_* VIR_DOMAIN_JOB_OPERATION*, VIR_MIGRATE_TLS - Add block threshold event - Add API for virDomainSetBlockThreshold Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Sys-Virt/Sys-Virt-3.3.0.ebuild')
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-3.3.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Sys-Virt/Sys-Virt-3.3.0.ebuild b/dev-perl/Sys-Virt/Sys-Virt-3.3.0.ebuild
new file mode 100644
index 000000000000..7cdc0637c826
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-3.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DANBERR
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=app-emulation/libvirt-${PV}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+PATCHES=( "${FILESDIR}/no-dot-inc.patch" )
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}
+
+src_test() {
+ perl_rm_files "t/010-pod-coverage.t" "t/005-pod.t" "t/015-changes.t"
+ perl-module_src_test
+}