summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-01-11 06:06:42 +1300
committerKent Fredric <kentnl@gentoo.org>2018-01-11 06:14:52 +1300
commitd06bd63a90784e328f25fdb065e1dfed735541ca (patch)
tree1599c803957486e64def0b056ceed111d04507b3 /dev-perl/Sys-Virt/Sys-Virt-3.9.1.ebuild
parentnet-misc/bfgminer: add alchemist to REQUIRED_USE for scrypt (diff)
downloadgentoo-d06bd63a90784e328f25fdb065e1dfed735541ca.tar.gz
gentoo-d06bd63a90784e328f25fdb065e1dfed735541ca.tar.bz2
gentoo-d06bd63a90784e328f25fdb065e1dfed735541ca.zip
dev-perl/Sys-Virt: Bump to version 3.9.1
Upstream: - Fix '.' in @INC - New constants: LIST_CAP_MDEV, LIST_CAP_MDEV_TYPES, RECV_STOP_AT_HOLE VOL_DOWNLOAD_SPARSE_STREAM, VOL_UPLOAD_SPARSE_STREAM, LIST_CAP_CCWD_DEV, VIR_DOMAIN_BLOCK_COPY_TRANSIENT_JOB, VIR_FROM_RESCTRL, VIR_STORAGE_POOL_EVENT_{DELETED,CREATED}, VIR_DOMAIN_JOB_MEMORY_PAGE_SIZE and domain event constants - Fix send_all() callback helper - Introduce flags to Stream::recv - Add methods: Stream::{{recv,send}_hole,sparce_{recv,send}_all}, migrate_get_max_downtime, managed_save_define_xml, managed_save_get_xml_description, set_lifecycle_action - Add vol-sparse.pl example - Fix package location of lifecycle constants Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Sys-Virt/Sys-Virt-3.9.1.ebuild')
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-3.9.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Sys-Virt/Sys-Virt-3.9.1.ebuild b/dev-perl/Sys-Virt/Sys-Virt-3.9.1.ebuild
new file mode 100644
index 000000000000..024ad6bd89fe
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-3.9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DANBERR
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=app-emulation/libvirt-${PV}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}
+
+src_test() {
+ perl_rm_files "t/010-pod-coverage.t" "t/005-pod.t" "t/015-changes.t"
+ perl-module_src_test
+}