summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-13 01:56:08 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-13 02:04:18 +0200
commit91f35f8d7afa551674fb2ea4398c0950d59eb2ff (patch)
tree91ba5ef1819e321a95f9eeb1c1b748f0215254dc /dev-perl/Sys-Virt/Sys-Virt-7.5.0.ebuild
parentdev-perl/Sys-Syscall: EAPI=8 bump (diff)
downloadgentoo-91f35f8d7afa551674fb2ea4398c0950d59eb2ff.tar.gz
gentoo-91f35f8d7afa551674fb2ea4398c0950d59eb2ff.tar.bz2
gentoo-91f35f8d7afa551674fb2ea4398c0950d59eb2ff.zip
dev-perl/Sys-Virt: Version bump 7.5.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Sys-Virt/Sys-Virt-7.5.0.ebuild')
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-7.5.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Sys-Virt/Sys-Virt-7.5.0.ebuild b/dev-perl/Sys-Virt/Sys-Virt-7.5.0.ebuild
new file mode 100644
index 000000000000..f3701419e511
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-7.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DANBERR
+DIST_VERSION=v${PV}
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-emulation/libvirt-${PV}
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ dev-perl/Module-Build
+ virtual/pkgconfig
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+DEPEND="
+ >=app-emulation/libvirt-${PV}
+"
+
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}
+
+src_test() {
+ perl_rm_files "t/010-pod-coverage.t" "t/005-pod.t" "t/015-changes.t"
+ perl-module_src_test
+}