summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Sys-Virt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Sys-Virt')
-rw-r--r--dev-perl/Sys-Virt/Manifest3
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-1.1.2.ebuild32
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-1.2.5.ebuild32
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-1.2.9.ebuild32
-rw-r--r--dev-perl/Sys-Virt/metadata.xml30
5 files changed, 129 insertions, 0 deletions
diff --git a/dev-perl/Sys-Virt/Manifest b/dev-perl/Sys-Virt/Manifest
new file mode 100644
index 000000000000..c04044713a67
--- /dev/null
+++ b/dev-perl/Sys-Virt/Manifest
@@ -0,0 +1,3 @@
+DIST Sys-Virt-1.1.2.tar.gz 95796 SHA256 51c3d23603781c535df1b56ee3137d8b83195f7250ee514658d580d328789792 SHA512 8648442bac2d0b1b33a96b8f5debade7c17c803140b717baca3b5f924e73677b1061b488c74e4cf9d07361c7fdaf7c4f6f393040778bdc47d4542dbf51e08430 WHIRLPOOL 5a325ed7a27591e41cfa7bfced84c400e65a273f616c5b382e0e4a259ca88e738ea6bc66d2ffc4b97de1b674005763c41b9c088aaae322e73c84a1f58e523b97
+DIST Sys-Virt-1.2.5.tar.gz 98341 SHA256 87fa8fb30c6b97311e71c72a7e97e23631b048d12d132a46b29c036e4faca776 SHA512 a8d5e760db1d7321889fe83fa0debee98f96776ab360f6f6925602d1fac092d41425e9993290ca1c91c5294e50ce0078cc34bb475163c0d5be64eb0ca8d289db WHIRLPOOL ab360098ea756e9b080885311d8f52181f19118db81338acc10b2d32bc4cbcc43ae26c75cd0646af371909dd2136022bb0f6ff4d86a82c63887f4b8f70adb4bc
+DIST Sys-Virt-1.2.9.tar.gz 103979 SHA256 87d643445774d4482dd46b8ad2e0f556b0241c57add782078ec3b835692de5a9 SHA512 d106180f9dc7b231a981d74ce55f6919c44711316ffb9c9ad0292427803040656dedb27b4295abb0e3f9637f0bec12c265c831a28a992e373f54145dd6999e04 WHIRLPOOL 1b9f9d3b0b62d77c6464c76acfa35f259f4345d3c3fb9beb34e6af7ad6b58e9b92ea1dd8d2d4e2894c98e154db99344e37e945f97c2b12d4961b65c8037004b2
diff --git a/dev-perl/Sys-Virt/Sys-Virt-1.1.2.ebuild b/dev-perl/Sys-Virt/Sys-Virt-1.1.2.ebuild
new file mode 100644
index 000000000000..f4fc7992aaae
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-1.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DANBERR
+MODULE_VERSION=1.1.2
+inherit perl-module
+
+DESCRIPTION="Sys::Virt provides an API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=">=app-emulation/libvirt-${PV}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-perl/CPAN-Changes
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+
+SRC_TEST="do"
+
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}
diff --git a/dev-perl/Sys-Virt/Sys-Virt-1.2.5.ebuild b/dev-perl/Sys-Virt/Sys-Virt-1.2.5.ebuild
new file mode 100644
index 000000000000..4ac4f7f29aa3
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-1.2.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DANBERR
+MODULE_VERSION=1.2.5
+inherit perl-module
+
+DESCRIPTION="Sys::Virt provides an API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=app-emulation/libvirt-${PV}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-perl/CPAN-Changes
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+
+SRC_TEST="do"
+
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}
diff --git a/dev-perl/Sys-Virt/Sys-Virt-1.2.9.ebuild b/dev-perl/Sys-Virt/Sys-Virt-1.2.9.ebuild
new file mode 100644
index 000000000000..fe47adb458a7
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-1.2.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DANBERR
+MODULE_VERSION=1.2.9
+inherit perl-module
+
+DESCRIPTION="Sys::Virt provides an API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=app-emulation/libvirt-${PV}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-perl/CPAN-Changes
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+
+SRC_TEST="do"
+
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}
diff --git a/dev-perl/Sys-Virt/metadata.xml b/dev-perl/Sys-Virt/metadata.xml
new file mode 100644
index 000000000000..042982179c9d
--- /dev/null
+++ b/dev-perl/Sys-Virt/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>andreis.vinogradovs@gmail.com</email>
+ <name>Andreis Vinogradovs</name>
+ </maintainer>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Sys-Virt</remote-id>
+ <remote-id type="cpan-module">Sys::Virt</remote-id>
+ <remote-id type="cpan-module">Sys::Virt::Domain</remote-id>
+ <remote-id type="cpan-module">Sys::Virt::DomainSnapshot</remote-id>
+ <remote-id type="cpan-module">Sys::Virt::Error</remote-id>
+ <remote-id type="cpan-module">Sys::Virt::Event</remote-id>
+ <remote-id type="cpan-module">Sys::Virt::Interface</remote-id>
+ <remote-id type="cpan-module">Sys::Virt::NWFilter</remote-id>
+ <remote-id type="cpan-module">Sys::Virt::Network</remote-id>
+ <remote-id type="cpan-module">Sys::Virt::NodeDevice</remote-id>
+ <remote-id type="cpan-module">Sys::Virt::Secret</remote-id>
+ <remote-id type="cpan-module">Sys::Virt::StoragePool</remote-id>
+ <remote-id type="cpan-module">Sys::Virt::StorageVol</remote-id>
+ <remote-id type="cpan-module">Sys::Virt::Stream</remote-id>
+ </upstream>
+</pkgmetadata>