summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <mprivozn@redhat.com>2022-03-17 10:40:41 +0100
committerSam James <sam@gentoo.org>2022-05-14 02:32:09 +0000
commit8d265389ef171cfdf4bce9370078eadbd0b70977 (patch)
tree9c0d0b3e76e7fbc54a4e629257c8010f0242f3aa /dev-perl/Sys-Virt
parentprofiles: unmask vtk-9.1 (diff)
downloadgentoo-8d265389ef171cfdf4bce9370078eadbd0b70977.tar.gz
gentoo-8d265389ef171cfdf4bce9370078eadbd0b70977.tar.bz2
gentoo-8d265389ef171cfdf4bce9370078eadbd0b70977.zip
dev-perl/Sys-Virt: Version bump 8.1.0
Signed-off-by: Michal Privoznik <mprivozn@redhat.com> Closes: https://github.com/gentoo/gentoo/pull/24618 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Sys-Virt')
-rw-r--r--dev-perl/Sys-Virt/Manifest1
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-8.1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Sys-Virt/Manifest b/dev-perl/Sys-Virt/Manifest
index a738c245ec62..6cb820c59ea8 100644
--- a/dev-perl/Sys-Virt/Manifest
+++ b/dev-perl/Sys-Virt/Manifest
@@ -1,2 +1,3 @@
DIST Sys-Virt-v7.0.0.tar.gz 165365 BLAKE2B 9cb7aa66ce00c95957171fedad4fefbae5319e17706e2839f8b3e057ab05c52b9d7e5ad222ad6aeecb7437e70bee9447a6a5845d729a93f10df3ffa4bbee0429 SHA512 c0ab179af11526a9dc983374765bd04400821f6f334d22f56b1f6452f54f880fe6882e9e0e121ae36010eb305d0632d574c969febefd8a32c9a731879d8fadb6
DIST Sys-Virt-v7.5.0.tar.gz 166656 BLAKE2B 466341cc081d1dedc0ad5ae9042a829256a310730aa410a93c795a983c6ee60099646d2a804626a076e435d3bd6d7742b4aa014f4642ee6b6078cd144b3cd8c0 SHA512 7da51e75fa53e81a68c32499ea865de0532fdb17f269b28310133d246be7dc59dfd6568850ffe66e393a7b7c2edbf4409618e2b461cdc35a62776ffbb97d7962
+DIST Sys-Virt-v8.1.0.tar.gz 169008 BLAKE2B 23d3aee186b4ede35c1b5b99691a491e64995abf34e7ce65143c7b88851dca0841cfa27a3033e246f35bacda879dd09c3b31f9dcff54d04c0d47a77b4b61d723 SHA512 9d7660f96cf370a0e08140bf7badddae2dac84d7231f1fe7a616650ac4d333ba17c6531ab0662f34c4cb12b00ce39abe36ff24a1913f554026346725d0148fa7
diff --git a/dev-perl/Sys-Virt/Sys-Virt-8.1.0.ebuild b/dev-perl/Sys-Virt/Sys-Virt-8.1.0.ebuild
new file mode 100644
index 000000000000..1bcadd8d9a03
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-8.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DANBERR
+DIST_VERSION=v${PV}
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-emulation/libvirt-${PV}
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ dev-perl/Module-Build
+ virtual/pkgconfig
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+DEPEND="
+ >=app-emulation/libvirt-${PV}
+"
+
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}