summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-13 21:30:31 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-15 21:55:31 +0200
commit8ec6f160cfb46258ffc9dd36923b076a8cabd53c (patch)
treeb4c66d09b73964af51c2d390ef115989da92582c /dev-perl/Term-Shell/Term-Shell-0.90.ebuild
parentdev-perl/Test-CPAN-Meta: Fix version normalisation. (diff)
downloadgentoo-8ec6f160cfb46258ffc9dd36923b076a8cabd53c.tar.gz
gentoo-8ec6f160cfb46258ffc9dd36923b076a8cabd53c.tar.bz2
gentoo-8ec6f160cfb46258ffc9dd36923b076a8cabd53c.zip
dev-perl/Term-Shell: Bump to version 0.90.0
- EAPI6 - USE "examples" - Tests cleaned up Upstream: - Mostly test and documentation enhancements Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Term-Shell/Term-Shell-0.90.ebuild')
-rw-r--r--dev-perl/Term-Shell/Term-Shell-0.90.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Term-Shell/Term-Shell-0.90.ebuild b/dev-perl/Term-Shell/Term-Shell-0.90.ebuild
new file mode 100644
index 000000000000..7a59b6deb6c0
--- /dev/null
+++ b/dev-perl/Term-Shell/Term-Shell-0.90.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=0.09
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="A simple command-line shell framework"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ >=virtual/perl-Getopt-Long-2.360.0
+ virtual/perl-IO
+ dev-perl/TermReadKey
+ virtual/perl-Term-ReadLine
+ dev-perl/Text-Autoformat
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files t/author-pod-syntax.t t/cpan-changes.t t/release-cpan-changes.t t/pod.t \
+ t/release-kwalitee.t t/release-trailing-space.t t/style-trailing-space.t
+ perl-module_src_test
+}