summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Test-CheckDeps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Test-CheckDeps')
-rw-r--r--dev-perl/Test-CheckDeps/Manifest2
-rw-r--r--dev-perl/Test-CheckDeps/Test-CheckDeps-0.10.0.ebuild33
-rw-r--r--dev-perl/Test-CheckDeps/Test-CheckDeps-0.2.0.ebuild24
-rw-r--r--dev-perl/Test-CheckDeps/metadata.xml9
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-perl/Test-CheckDeps/Manifest b/dev-perl/Test-CheckDeps/Manifest
new file mode 100644
index 000000000000..42039ba08402
--- /dev/null
+++ b/dev-perl/Test-CheckDeps/Manifest
@@ -0,0 +1,2 @@
+DIST Test-CheckDeps-0.002.tar.gz 10964 SHA256 2696298bbf0720af39ea3b82db583ec280db0dcb2c9b85574a85aaf8744fb53a SHA512 ddaeee6b6d489faf1128d82a339c632ba5ea504da3d5d25892f02cc6455a44da9957fa963af6726812d58b5f6dc8547bfd7f42efab17aa2603314966815e28f5 WHIRLPOOL 84f8a518d70c080aad996e68020fdb2f427c149c8284bbbfa76a5557d12500292fc72498fac4e4a129588ffeddcf6e623b8baf4b511820be2aaa5e2d19629319
+DIST Test-CheckDeps-0.010.tar.gz 11822 SHA256 66fccca6c6f330e7ecc898bd6a51846e2145b3e02d78c4997ba6b7de23b551ee SHA512 9683b81aa6bce358fa1abc9b2337b9b15b274742f08a3fd71e80df0bfd20619406cdded191aafdd103db8d514bdc20d36a0b60aefbd72d3de6cb117c17461697 WHIRLPOOL 2422ce4fbfac8ea32ae170a18826e734bb57d017d18148333e83ab624ff6d0c43fb29629286f0f5c79684d35cd84b2850be01aa38abad339a5bcae251866348f
diff --git a/dev-perl/Test-CheckDeps/Test-CheckDeps-0.10.0.ebuild b/dev-perl/Test-CheckDeps/Test-CheckDeps-0.10.0.ebuild
new file mode 100644
index 000000000000..445341d4dc9b
--- /dev/null
+++ b/dev-perl/Test-CheckDeps/Test-CheckDeps-0.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LEONT
+MODULE_VERSION=0.010
+inherit perl-module
+
+DESCRIPTION='Check for presence of dependencies'
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="test"
+
+# rdep Test::Builder -> perl-Test-Simple
+RDEPEND="
+ >=virtual/perl-CPAN-Meta-2.120.920
+ >=dev-perl/CPAN-Meta-Check-0.7.0
+ >=virtual/perl-Exporter-5.570.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test-Simple
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Test-CheckDeps/Test-CheckDeps-0.2.0.ebuild b/dev-perl/Test-CheckDeps/Test-CheckDeps-0.2.0.ebuild
new file mode 100644
index 000000000000..e2c0366540e9
--- /dev/null
+++ b/dev-perl/Test-CheckDeps/Test-CheckDeps-0.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LEONT
+MODULE_VERSION=0.002
+inherit perl-module
+
+DESCRIPTION='Check for presence of dependencies'
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-CPAN-Meta
+ dev-perl/CPAN-Meta-Check
+ virtual/perl-Module-Metadata
+"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Test-CheckDeps/metadata.xml b/dev-perl/Test-CheckDeps/metadata.xml
new file mode 100644
index 000000000000..172ddd9c6c0a
--- /dev/null
+++ b/dev-perl/Test-CheckDeps/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Test-CheckDeps</remote-id>
+ <remote-id type="cpan-module">Test::CheckDeps</remote-id>
+ </upstream>
+</pkgmetadata>