summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-12-09 13:04:44 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-12-09 13:05:33 +0100
commit9e2b454134d230bc327399375c94274d9880dfbb (patch)
tree8f61c54abe09956e99f37b83f96abb0e9644774b /dev-perl/Test-Compile
parentdev-perl/Test-Compile: Remove old (diff)
downloadgentoo-9e2b454134d230bc327399375c94274d9880dfbb.tar.gz
gentoo-9e2b454134d230bc327399375c94274d9880dfbb.tar.bz2
gentoo-9e2b454134d230bc327399375c94274d9880dfbb.zip
dev-perl/Test-Compile: Version bump 3.0.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Test-Compile')
-rw-r--r--dev-perl/Test-Compile/Manifest1
-rw-r--r--dev-perl/Test-Compile/Test-Compile-3.0.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Test-Compile/Manifest b/dev-perl/Test-Compile/Manifest
index 6bcd1cb2c343..f9fbe81b7053 100644
--- a/dev-perl/Test-Compile/Manifest
+++ b/dev-perl/Test-Compile/Manifest
@@ -1 +1,2 @@
DIST Test-Compile-v2.4.2.tar.gz 18842 BLAKE2B 6bc8dbd692087ccbf41b227c417f1cb8a100ea2e845289fae52ce8f375c4f7970f759ab2fffcb19af7670ec93f92115812184d9d71f73db21628b4937b6e84c9 SHA512 3c16249d9cf14c3cc1dae5958c591b9beac320e26c3ef958a76ca74763ce30443ebe55e3e4efacd384252dfe1ef1cfca9c12d4f7a67780e0db20d6462b6d541c
+DIST Test-Compile-v3.0.1.tar.gz 18490 BLAKE2B d472567065549a6a00c668aa5d7af1597f5d3fe0f06a849b374fe0b6757ef5a591ddb5834c894c64c48d9eabe5112803509dba9b4698afed6e028a5010ae4b5f SHA512 a8e5d0fabaaa0c8d4de716da85279c8d4abdcfb8e453159f5b47d10e1845d2f80164d099bcd3906d74afae1137fd9d4430d47b8bdcb3afc6d81b8043bd585715
diff --git a/dev-perl/Test-Compile/Test-Compile-3.0.1.ebuild b/dev-perl/Test-Compile/Test-Compile-3.0.1.ebuild
new file mode 100644
index 000000000000..2678d51cf437
--- /dev/null
+++ b/dev-perl/Test-Compile/Test-Compile-3.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=EGILES
+DIST_VERSION=v${PV}
+inherit perl-module
+
+DESCRIPTION="Check whether Perl files compile correctly"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ >=virtual/perl-Exporter-5.680.0
+ >=virtual/perl-parent-0.225.0
+ virtual/perl-version
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=(
+ t/999-has-version.t
+ t/999-perlcritic.t
+ t/999-pod-coverage.t
+ t/999-pod.t
+ t/999-portability.t
+ t/999-synopsis.t
+ t/999-version.t
+)