summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2015-09-19 22:29:21 +0200
committerAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2015-09-19 23:06:14 +0200
commit48fcf714604b59f75f250b24abd8a39eaa60ff98 (patch)
tree31d2d722867892de56c952f11bb3773dc4ada3da /dev-perl/Test-Exception
parentdev-perl/Test-LongString: Version bump (diff)
downloadgentoo-48fcf714604b59f75f250b24abd8a39eaa60ff98.tar.gz
gentoo-48fcf714604b59f75f250b24abd8a39eaa60ff98.tar.bz2
gentoo-48fcf714604b59f75f250b24abd8a39eaa60ff98.zip
dev-perl/Test-Exception: Version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-perl/Test-Exception')
-rw-r--r--dev-perl/Test-Exception/Manifest1
-rw-r--r--dev-perl/Test-Exception/Test-Exception-0.400.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Test-Exception/Manifest b/dev-perl/Test-Exception/Manifest
index 227a951d6caf..a2bc6e1e1f12 100644
--- a/dev-perl/Test-Exception/Manifest
+++ b/dev-perl/Test-Exception/Manifest
@@ -1,2 +1,3 @@
DIST Test-Exception-0.32.tar.gz 18131 SHA256 ba4427e6004797ece8dce93c61d1d6c82df891b0f017e7d4a5c2505fa05c5a47 SHA512 fd394c2e3d24fc822810b77bd3bfe12ca75f59519ac0a0307f028be84a48386d12273967f0431f8c3a6671762c6426523420f620621ba7332c3268bc3a0706af WHIRLPOOL db6bdfbd4d1d45991ee9ecd78af37cc19911620a585a3284716faf3f80458194956ee8339a738fd3723b5b428bca4d70cff4467e30a3ce1b719c3a60239414d0
DIST Test-Exception-0.38.tar.gz 15349 SHA256 7c6aa4c208c043c38631e2af8d28abf76d32a3dcd2ff4a94591f009a6ed3eab5 SHA512 9c0176e8d5bcf803ccec4e980ebc6057f15b5cd40c4df422c1e5a87db7df8f18f5f623340190ac9010b67eba7c0c1a1ede83b54ea18dca704d937d5bcb8c6d78 WHIRLPOOL e807354608b3eecb4f9d4806e6862f12d389a830f311a916da089c49023332382f7de82c94da4a81369f3f6d8a2c72a26882f04b6096d15249ba0e16aef46b52
+DIST Test-Exception-0.40.tar.gz 14801 SHA256 d92ccb566d93140abc93b07ec4c13e9b14c8f8f7d7858a2ab575d83b3bb51b26 SHA512 cf85ef0d1991b0797a5823f827a9ad33ceac78f163b97afab19e9c3a11e3cf7505c5a37518dadb5636db42f0337f53df8e0045a5f3fe2200159ee4d83a591902 WHIRLPOOL b141d86bda79b30ad3f040f63d65e34e119b463f1b0f4c0e591a8d42b1149ff3554f6537477278ffc36549451a9634195d512c3fc6249b50e3088b8e1cadbe7d
diff --git a/dev-perl/Test-Exception/Test-Exception-0.400.0.ebuild b/dev-perl/Test-Exception/Test-Exception-0.400.0.ebuild
new file mode 100644
index 000000000000..d5dfedd4de82
--- /dev/null
+++ b/dev-perl/Test-Exception/Test-Exception-0.400.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=EXODIST
+MODULE_VERSION=0.40
+inherit perl-module
+
+DESCRIPTION="Test functions for exception based code"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ >=dev-perl/Sub-Uplevel-0.180.0
+ virtual/perl-Test-Simple
+ >=virtual/perl-Test-Harness-2.30.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+SRC_TEST="do parallel"