summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Test-Exception
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Test-Exception')
-rw-r--r--dev-perl/Test-Exception/Manifest2
-rw-r--r--dev-perl/Test-Exception/Test-Exception-0.320.0-r1.ebuild22
-rw-r--r--dev-perl/Test-Exception/Test-Exception-0.380.0.ebuild27
-rw-r--r--dev-perl/Test-Exception/metadata.xml9
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-perl/Test-Exception/Manifest b/dev-perl/Test-Exception/Manifest
new file mode 100644
index 000000000000..227a951d6caf
--- /dev/null
+++ b/dev-perl/Test-Exception/Manifest
@@ -0,0 +1,2 @@
+DIST Test-Exception-0.32.tar.gz 18131 SHA256 ba4427e6004797ece8dce93c61d1d6c82df891b0f017e7d4a5c2505fa05c5a47 SHA512 fd394c2e3d24fc822810b77bd3bfe12ca75f59519ac0a0307f028be84a48386d12273967f0431f8c3a6671762c6426523420f620621ba7332c3268bc3a0706af WHIRLPOOL db6bdfbd4d1d45991ee9ecd78af37cc19911620a585a3284716faf3f80458194956ee8339a738fd3723b5b428bca4d70cff4467e30a3ce1b719c3a60239414d0
+DIST Test-Exception-0.38.tar.gz 15349 SHA256 7c6aa4c208c043c38631e2af8d28abf76d32a3dcd2ff4a94591f009a6ed3eab5 SHA512 9c0176e8d5bcf803ccec4e980ebc6057f15b5cd40c4df422c1e5a87db7df8f18f5f623340190ac9010b67eba7c0c1a1ede83b54ea18dca704d937d5bcb8c6d78 WHIRLPOOL e807354608b3eecb4f9d4806e6862f12d389a830f311a916da089c49023332382f7de82c94da4a81369f3f6d8a2c72a26882f04b6096d15249ba0e16aef46b52
diff --git a/dev-perl/Test-Exception/Test-Exception-0.320.0-r1.ebuild b/dev-perl/Test-Exception/Test-Exception-0.320.0-r1.ebuild
new file mode 100644
index 000000000000..a5a7f3526698
--- /dev/null
+++ b/dev-perl/Test-Exception/Test-Exception-0.320.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ADIE
+MODULE_VERSION=0.32
+inherit perl-module
+
+DESCRIPTION="test functions for exception based code"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=virtual/perl-Test-Simple-0.64
+ >=dev-perl/Sub-Uplevel-0.18"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.36"
+
+SRC_TEST="do"
diff --git a/dev-perl/Test-Exception/Test-Exception-0.380.0.ebuild b/dev-perl/Test-Exception/Test-Exception-0.380.0.ebuild
new file mode 100644
index 000000000000..7f49ab64e1a2
--- /dev/null
+++ b/dev-perl/Test-Exception/Test-Exception-0.380.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=0.38
+inherit perl-module
+
+DESCRIPTION="Test functions for exception based code"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ >=dev-perl/Sub-Uplevel-0.180.0
+ virtual/perl-Test-Simple
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Test-Exception/metadata.xml b/dev-perl/Test-Exception/metadata.xml
new file mode 100644
index 000000000000..14adf3bbfea5
--- /dev/null
+++ b/dev-perl/Test-Exception/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Test-Exception</remote-id>
+ <remote-id type="cpan-module">Test::Exception</remote-id>
+ </upstream>
+</pkgmetadata>