summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-18 23:40:01 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-18 23:46:02 +0200
commit6ffcd9d9d54f6df8ee28614518bd44ccd7529ed5 (patch)
treedd3d47432176c7490bfc6ad939ba4692480e0663 /dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild
parentdev-perl/Test-Exception: EAPI=8 bump (diff)
downloadgentoo-6ffcd9d9d54f6df8ee28614518bd44ccd7529ed5.tar.gz
gentoo-6ffcd9d9d54f6df8ee28614518bd44ccd7529ed5.tar.bz2
gentoo-6ffcd9d9d54f6df8ee28614518bd44ccd7529ed5.zip
dev-perl/Test-FailWarnings: EAPI=8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild')
-rw-r--r--dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild b/dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild
new file mode 100644
index 000000000000..38254a409686
--- /dev/null
+++ b/dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=0.008
+inherit perl-module
+
+DESCRIPTION="Add test failures if warnings are caught"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+LICENSE="Apache-2.0"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.860.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Capture-Tiny-0.120.0
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"