summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-20 08:40:02 +0000
committerSam James <sam@gentoo.org>2023-03-20 08:40:18 +0000
commit2675bf61c31e63d53fa69097ce5ec198d923b6a8 (patch)
tree1b8cba453ead7aceac9b2d9c46fc3c10c687d493 /dev-perl/Test-File/Test-File-1.993.0.ebuild
parentdev-perl/Test-File-Contents: add 0.242.0 (diff)
downloadgentoo-2675bf61c31e63d53fa69097ce5ec198d923b6a8.tar.gz
gentoo-2675bf61c31e63d53fa69097ce5ec198d923b6a8.tar.bz2
gentoo-2675bf61c31e63d53fa69097ce5ec198d923b6a8.zip
dev-perl/Test-File: add 1.993.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Test-File/Test-File-1.993.0.ebuild')
-rw-r--r--dev-perl/Test-File/Test-File-1.993.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Test-File/Test-File-1.993.0.ebuild b/dev-perl/Test-File/Test-File-1.993.0.ebuild
new file mode 100644
index 000000000000..92dd5966de98
--- /dev/null
+++ b/dev-perl/Test-File/Test-File-1.993.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=BDFOY
+DIST_VERSION=1.993
+inherit perl-module
+
+DESCRIPTION="Test file attributes"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ >=virtual/perl-Test-Simple-0.950.0
+ )
+"
+
+src_prepare() {
+ if use test; then
+ perl_rm_files t/pod.t t/pod_coverage.t t/test_manifest
+ sed -i -e '/Test::Manifest/d' Makefile.PL || die "Can't patch Makefile.PL"
+ fi
+ perl-module_src_prepare
+}