summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-19 02:12:40 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-19 02:14:50 +0200
commit9fe331d438aef3faee80352429d9949850a9c833 (patch)
tree685b9433b29f42cbe67d333b4d651c681c41e8ba /dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild
parentdev-perl/Test-LongString: EAPI=8 bump (diff)
downloadgentoo-9fe331d438aef3faee80352429d9949850a9c833.tar.gz
gentoo-9fe331d438aef3faee80352429d9949850a9c833.tar.bz2
gentoo-9fe331d438aef3faee80352429d9949850a9c833.zip
dev-perl/Test-Manifest: Version bump 2.022
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild')
-rw-r--r--dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild b/dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild
new file mode 100644
index 000000000000..f274d3497bb4
--- /dev/null
+++ b/dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=BDFOY
+DIST_VERSION=2.022
+inherit perl-module
+
+DESCRIPTION="Interact with a t/test_manifest file"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+LICENSE="Artistic-2"
+
+RDEPEND="
+ virtual/perl-File-Spec
+ virtual/perl-Test-Harness
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ virtual/perl-File-Temp
+ >=virtual/perl-Test-Simple-1.0.0
+ )
+"
+
+src_test() {
+ # Ugh, Upstream has tests that depend on tests ...
+ echo 'print qq[1..1\nok 1];' > "${S}/t/99pod.t"
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod_coverage.t"
+ perl-module_src_test
+}