summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-07-17 21:07:12 +1200
committerKent Fredric <kentnl@gentoo.org>2019-07-17 21:07:25 +1200
commite4a6b01fad01cdfffb90547cc9aa1fbb4d37cc06 (patch)
tree7bd8067ba083af11d5145e9ae266d51536a0cdb4 /dev-perl/Test-Timer/Test-Timer-2.100.0.ebuild
parentapp-emulation/virtualbox: Removed double empty line (diff)
downloadgentoo-e4a6b01fad01cdfffb90547cc9aa1fbb4d37cc06.tar.gz
gentoo-e4a6b01fad01cdfffb90547cc9aa1fbb4d37cc06.tar.bz2
gentoo-e4a6b01fad01cdfffb90547cc9aa1fbb4d37cc06.zip
dev-perl/Test-Timer: Bump to version 2.100.0 re bug #649846
Upstream: - Tests now less sensitive to load problems - Restore use of sleep instead of select in tests - Remove redundant tests - Elimiate use of regexp for parsing benchmark output Bug: https://bugs.gentoo.org/649846 Bug: https://github.com/jonasbn/perl-test-timer/issues/17 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Test-Timer/Test-Timer-2.100.0.ebuild')
-rw-r--r--dev-perl/Test-Timer/Test-Timer-2.100.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Test-Timer/Test-Timer-2.100.0.ebuild b/dev-perl/Test-Timer/Test-Timer-2.100.0.ebuild
new file mode 100644
index 000000000000..3495c3d01931
--- /dev/null
+++ b/dev-perl/Test-Timer/Test-Timer-2.100.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=JONASBN
+DIST_VERSION=2.10
+inherit perl-module
+
+DESCRIPTION="test module to test/assert response times"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Error
+ virtual/perl-Test-Simple
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.300.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-1.302.111
+ )
+"
+PATCHES=("${FILESDIR}/${PN}-${DIST_VERSION}-prereqs.patch")
+src_prepare() {
+ perl_rm_files t/author-* t/release-*
+ perl-module_src_prepare
+}