summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-17 10:11:05 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-23 19:30:44 +0200
commit24e3789720a1413a8246035e1edbda997f8c8092 (patch)
tree3b19c2909453c719bfcf89875b5e713318d5eecd /dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild
parentdev-perl/Test-YAML: Bump to version 1.60.0 (diff)
downloadgentoo-24e3789720a1413a8246035e1edbda997f8c8092.tar.gz
gentoo-24e3789720a1413a8246035e1edbda997f8c8092.tar.bz2
gentoo-24e3789720a1413a8246035e1edbda997f8c8092.zip
dev-perl/Text-Aligner: Bump to version 0.130.0
- EAPI6 - Fixup tests Upstream: - Relicense under ISC/MIT - Documentation improvements - Fixed warning on newer perls. Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild')
-rw-r--r--dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild b/dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild
new file mode 100644
index 000000000000..cc32058e9fe0
--- /dev/null
+++ b/dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=0.13
+inherit perl-module
+
+DESCRIPTION="Used to justify strings to various alignment styles"
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Exporter
+ >=virtual/perl-Term-ANSIColor-2.20.0"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files t/release-{cpan-changes,kwalitee,trailing-space}.t \
+ t/author-{no-tabs,pod-{coverage,syntax}}.t
+
+ perl-module_src_test
+}