summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-02-20 01:43:32 +1300
committerKent Fredric <kentnl@gentoo.org>2017-02-20 02:11:45 +1300
commitf190295451ed1b4aa8c249c5bd6682c180663200 (patch)
tree2a46b89713c29a789760c205b1744e64f7a840da /dev-perl/Text-CSV/Text-CSV-1.910.0.ebuild
parentdev-perl/PDF-API2: Bump to version 2.310.0 (diff)
downloadgentoo-f190295451ed1b4aa8c249c5bd6682c180663200.tar.gz
gentoo-f190295451ed1b4aa8c249c5bd6682c180663200.tar.bz2
gentoo-f190295451ed1b4aa8c249c5bd6682c180663200.zip
dev-perl/Text-CSV: Bump to version 1.910.0
- EAPI6 - Parallel Testing - Add USE=xs on by default for speed Upstream: - Significant rewrite to be closer in behaviour to Text::CSV_XS Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl/Text-CSV/Text-CSV-1.910.0.ebuild')
-rw-r--r--dev-perl/Text-CSV/Text-CSV-1.910.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Text-CSV/Text-CSV-1.910.0.ebuild b/dev-perl/Text-CSV/Text-CSV-1.910.0.ebuild
new file mode 100644
index 000000000000..98b3c0e67836
--- /dev/null
+++ b/dev-perl/Text-CSV/Text-CSV-1.910.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=ISHIGAKI
+DIST_VERSION=1.91
+inherit perl-module
+
+DESCRIPTION="Manipulate comma-separated value strings"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test +xs"
+
+RDEPEND="
+ xs? ( >=dev-perl/Text-CSV_XS-1.20.0 )
+ virtual/perl-IO
+"
+DEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/00_pod.t
+ perl-module_src_test
+}