summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-09 21:04:53 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-09 21:05:14 +1300
commitf0f0ee84e70c3c19cb3d93241c6224c914b4a0cf (patch)
tree3c35c221ac5e7a7627e28e2b88fbaa6018f6cbda /dev-perl/Text-CSV_XS/Text-CSV_XS-1.340.0.ebuild
parentdev-lisp/clisp: Removes unused patches (diff)
downloadgentoo-f0f0ee84e70c3c19cb3d93241c6224c914b4a0cf.tar.gz
gentoo-f0f0ee84e70c3c19cb3d93241c6224c914b4a0cf.tar.bz2
gentoo-f0f0ee84e70c3c19cb3d93241c6224c914b4a0cf.zip
dev-perl/Text-CSV_XS: Bump to version 1.340.0
Upstream: - Disable escape_null for undef escape_char - Fix ->say for bound columns - Fix already decoded BOM in headers - new options in csv-check - add alias "escape" for "escape_char" - Improve csv-check auto-sep detection - Add keep_headers attribute to csv() - Fix on_in when used in combination with key - Fail on invalid arguments to csv - Fix header method on EOL = CR - Add support for formula actions - reset file info on ->header call - Bad arg for formula will now die with error 1500 - Fix row report in formula being off by 1 - Make sheet label more portable - Allow munge => \%hash - Preserve first row in csv Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Text-CSV_XS/Text-CSV_XS-1.340.0.ebuild')
-rw-r--r--dev-perl/Text-CSV_XS/Text-CSV_XS-1.340.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Text-CSV_XS/Text-CSV_XS-1.340.0.ebuild b/dev-perl/Text-CSV_XS/Text-CSV_XS-1.340.0.ebuild
new file mode 100644
index 000000000000..e68f8bebc72d
--- /dev/null
+++ b/dev-perl/Text-CSV_XS/Text-CSV_XS-1.340.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=HMBRAND
+DIST_A_EXT=tgz
+DIST_VERSION=1.34
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Comma-separated values manipulation routines"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-IO
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=("t/00_pod.t" "t/01_pod.t")