summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-20 21:51:12 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-20 21:52:09 +1300
commitd203132b068a0817c8be79889d385f9b8331c5a9 (patch)
tree83e1315dc1942a010ae4149b2e03e878d4135539 /dev-perl/Video-ivtv/Video-ivtv-0.13-r2.ebuild
parentdev-perl/Video-Frequencies: EAPI6 + tests (diff)
downloadgentoo-d203132b068a0817c8be79889d385f9b8331c5a9.tar.gz
gentoo-d203132b068a0817c8be79889d385f9b8331c5a9.tar.bz2
gentoo-d203132b068a0817c8be79889d385f9b8331c5a9.zip
dev-perl/Video-ivtv: EAPI6 + tests
- EAPI6ify - Add rudimentary tests - Add "I'm an adult" features to force test Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Video-ivtv/Video-ivtv-0.13-r2.ebuild')
-rw-r--r--dev-perl/Video-ivtv/Video-ivtv-0.13-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Video-ivtv/Video-ivtv-0.13-r2.ebuild b/dev-perl/Video-ivtv/Video-ivtv-0.13-r2.ebuild
new file mode 100644
index 000000000000..7d62cb7029de
--- /dev/null
+++ b/dev-perl/Video-ivtv/Video-ivtv-0.13-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit perl-module
+
+DESCRIPTION="Video::ivtv perl module, for use with ivtv-ptune"
+HOMEPAGE="http://ivtv.sourceforge.net"
+SRC_URI="mirror://sourceforge/ivtv/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ export OPTIMIZE="$CFLAGS"
+ perl-module_src_configure
+}
+
+# Requires /dev/video0 access, set DIST_TEST_OVERRIDE
+# to circumvent
+DIST_TEST="skip"
+
+src_test() {
+ ebegin "Compile testing Video::ivtv ${PV}"
+ perl -Mblib="${S}" -M"Video::ivtv ${PV} ()" -e1
+ if ! eend $?; then
+ echo
+ eerror "One or more modules failed compile:";
+ eerror " Video::ivtv ${PV}"
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}