summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-07-17 21:47:02 +1200
committerKent Fredric <kentnl@gentoo.org>2019-07-17 21:47:16 +1200
commitf57ae9cd3c97d6f33bc040901ec07f2cd354efa9 (patch)
treec3cb77c911dffbe8b46b6fe632707e953a41532c /dev-perl/WWW-Mechanize/WWW-Mechanize-1.910.0.ebuild
parentelisp.eclass: Drop support for EAPIs 0 to 3. (diff)
downloadgentoo-f57ae9cd3c97d6f33bc040901ec07f2cd354efa9.tar.gz
gentoo-f57ae9cd3c97d6f33bc040901ec07f2cd354efa9.tar.bz2
gentoo-f57ae9cd3c97d6f33bc040901ec07f2cd354efa9.zip
dev-perl/WWW-Mechanize: Bump to version 1.910.0 for bug #664006
- Honestly, I have no idea if it will help, but its worth trying Upstream: - tick() now dies if checkbox is not found - Add support to find_image and find_all_images via 'id' and 'class' - Pass strict/verbose constructor args to HTML::Form - Add ability to clear history - Ensure support for weak referencs in HTML::Element Bug: https://bugs.gentoo.org/664006 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/WWW-Mechanize/WWW-Mechanize-1.910.0.ebuild')
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.910.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.910.0.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.910.0.ebuild
new file mode 100644
index 000000000000..306cb742f028
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.910.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=OALDERS
+DIST_VERSION=1.91
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Getopt-Long
+ dev-perl/HTML-Form
+ >=dev-perl/HTML-Parser-3.340.0
+ >=dev-perl/HTML-Tree-5
+ dev-perl/HTTP-Cookies
+ dev-perl/HTTP-Message
+ >=dev-perl/libwww-perl-5.827.0
+ >=virtual/perl-Scalar-List-Utils-1.140.0
+ virtual/perl-Tie-RefHash
+ >=dev-perl/URI-1.360.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/CGI-4.320.0
+ virtual/perl-Exporter
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/HTTP-Daemon
+ dev-perl/HTTP-Server-Simple
+ dev-perl/Test-Deep
+ dev-perl/Test-Fatal
+ dev-perl/Test-Output
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Test-Warnings
+ )
+"