summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-09-24 20:40:22 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-09-24 20:58:06 +0200
commit24553e5cb7dc973b1a7d90364bd821450a276af2 (patch)
tree36a3cb256535eb5e31f8e66433513d02d6e8d539 /dev-perl/XML-LibXML/XML-LibXML-2.12.800.ebuild
parentdev-perl/XML-LibXML: Remove old (diff)
downloadgentoo-24553e5cb7dc973b1a7d90364bd821450a276af2.tar.gz
gentoo-24553e5cb7dc973b1a7d90364bd821450a276af2.tar.bz2
gentoo-24553e5cb7dc973b1a7d90364bd821450a276af2.zip
dev-perl/XML-LibXML: Version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-perl/XML-LibXML/XML-LibXML-2.12.800.ebuild')
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-2.12.800.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-perl/XML-LibXML/XML-LibXML-2.12.800.ebuild b/dev-perl/XML-LibXML/XML-LibXML-2.12.800.ebuild
new file mode 100644
index 000000000000..8299b2721af9
--- /dev/null
+++ b/dev-perl/XML-LibXML/XML-LibXML-2.12.800.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=2.0128
+DIST_EXAMPLES=("example/*")
+inherit perl-module
+
+DESCRIPTION="Perl binding for libxml2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test minimal"
+
+RDEPEND="
+ >=dev-perl/XML-SAX-0.120.0
+ >=dev-libs/libxml2-2.6.21
+ dev-perl/XML-SAX-Base
+ >=dev-perl/XML-NamespaceSupport-1.70.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ dev-perl/Test-LeakTrace
+ )
+ )
+"
+
+src_compile() {
+ export SKIP_SAX_INSTALL=1
+ perl-module_src_compile
+}
+
+src_test() {
+ perl_rm_files t/pod.t t/style-trailing-space.t t/cpan-changes.t
+ perl-module_src_test
+}
+
+pkg_postinst() {
+ pkg_update_parser add XML::LibXML::SAX::Parser
+ pkg_update_parser add XML::LibXML::SAX
+}
+
+pkg_postrm() {
+ pkg_update_parser remove XML::LibXML::SAX::Parser
+ pkg_update_parser remove XML::LibXML::SAX
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}