summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-04 00:34:25 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-04 00:47:25 +0200
commit4d16732b49987f6a6fdbc589d183233cbb9a7ff9 (patch)
tree06264079bc5a600833f6026c44edbb220e08c39e /dev-perl/XML-LibXML
parentdev-perl/XML-LibXML: Remove old (diff)
downloadgentoo-4d16732b49987f6a6fdbc589d183233cbb9a7ff9.tar.gz
gentoo-4d16732b49987f6a6fdbc589d183233cbb9a7ff9.tar.bz2
gentoo-4d16732b49987f6a6fdbc589d183233cbb9a7ff9.zip
dev-perl/XML-LibXML: Version bump 2.0207
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/XML-LibXML')
-rw-r--r--dev-perl/XML-LibXML/Manifest1
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-2.20.700.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-perl/XML-LibXML/Manifest b/dev-perl/XML-LibXML/Manifest
index d8e1947e0457..a167ef250d89 100644
--- a/dev-perl/XML-LibXML/Manifest
+++ b/dev-perl/XML-LibXML/Manifest
@@ -1 +1,2 @@
DIST XML-LibXML-2.0201.tar.gz 462237 BLAKE2B 17313daca3e87b12f0d3161f628dbd5ee3fbd233747a9602b275e13f14e9710eba424804b1f57b40c2f0f340d1c29ca0518ffc395b808b0e9851c61943d73b22 SHA512 988bc98e7f3e426202b9770ef055df68abc861b935dcdd8ecbefaaa7cd528abc35cce9bd75f2f10412917178f6b74ac6bf953feac130b1f9afe9e18c16139e47
+DIST XML-LibXML-2.0207.tar.gz 462595 BLAKE2B 9ebb4786dcd45f552ef31ba0854693e876b6f8098b577401429651e5eb55792bb623185db371d2578432c00031ce2cfb66603e08290d7cf8f74dee5fe45c143d SHA512 86bf4200c800e1295161c3217892398dbc65e107ad1a3df8ea7f237350ba67d88ad7b18ab7123e647053a8721bc13a8959ddb101fdc6de18dcaef02c0f0f5b58
diff --git a/dev-perl/XML-LibXML/XML-LibXML-2.20.700.ebuild b/dev-perl/XML-LibXML/XML-LibXML-2.20.700.ebuild
new file mode 100644
index 000000000000..1d213896cdab
--- /dev/null
+++ b/dev-perl/XML-LibXML/XML-LibXML-2.20.700.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=2.0207
+DIST_EXAMPLES=("example/*")
+inherit perl-module
+
+DESCRIPTION="Perl binding for libxml2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="minimal"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ >=virtual/perl-Exporter-5.570.0
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/XML-NamespaceSupport-1.70.0
+ >=dev-perl/XML-SAX-0.110.0
+ dev-perl/XML-SAX-Base
+ >=dev-libs/libxml2-2.6.21:2=
+ virtual/perl-parent
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/Alien-Build
+ >=dev-perl/Alien-Libxml2-0.140.0
+ test? (
+ !minimal? (
+ dev-perl/Test-LeakTrace
+ )
+ )
+"
+DEPEND=">=dev-libs/libxml2-2.6.21:2=
+"
+
+PERL_RM_FILES=(
+ "t/cpan-changes.t" "t/pod-files-presence.t" "t/pod.t"
+ "t/release-kwalitee.t" "t/style-trailing-space.t"
+ "t/11memory.t"
+)
+
+src_compile() {
+ export SKIP_SAX_INSTALL=1
+ perl-module_src_compile
+}
+
+pkg_postinst() {
+ pkg_update_parser add XML::LibXML::SAX::Parser
+ pkg_update_parser add XML::LibXML::SAX
+}
+
+pkg_postrm() {
+ pkg_update_parser remove XML::LibXML::SAX::Parser
+ pkg_update_parser remove XML::LibXML::SAX
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}