summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-28 18:08:38 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-28 18:09:07 +1300
commit95012db24fd9d6d9ccd0f8480995ad6879ede4e9 (patch)
treebad41f39758fd1136fd7d87bf8ae93167df87341 /dev-perl/XML-RSS/XML-RSS-1.600.0.ebuild
parentdev-vcs/bzr: arm stable, bug #646764 (diff)
downloadgentoo-95012db24fd9d6d9ccd0f8480995ad6879ede4e9.tar.gz
gentoo-95012db24fd9d6d9ccd0f8480995ad6879ede4e9.tar.bz2
gentoo-95012db24fd9d6d9ccd0f8480995ad6879ede4e9.zip
dev-perl/XML-RSS: Bump to version 1.600.0
Upstream: - Remove manifest test stuff - Packaging fixes Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/XML-RSS/XML-RSS-1.600.0.ebuild')
-rw-r--r--dev-perl/XML-RSS/XML-RSS-1.600.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/XML-RSS/XML-RSS-1.600.0.ebuild b/dev-perl/XML-RSS/XML-RSS-1.600.0.ebuild
new file mode 100644
index 000000000000..489b65090772
--- /dev/null
+++ b/dev-perl/XML-RSS/XML-RSS-1.600.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=1.60
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="a basic framework for creating and maintaining RSS files"
+HOMEPAGE="http://perl-rss.sourceforge.net/"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/DateTime-Format-Mail
+ dev-perl/DateTime-Format-W3CDTF
+ dev-perl/HTML-Parser
+ >=dev-perl/XML-Parser-2.230.0"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+PERL_RM_FILES=(
+ "t/pod.t" "t/pod-coverage.t"
+ "t/cpan-changes.t" "t/style-trailing-space.t"
+)