summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-06 18:33:18 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-06 18:47:14 +0200
commit4dd9670e7f208c361cf3035ad0ec477a8acf52bf (patch)
tree7dbb9f1d480b34c58de04f5821382eb79ee57d3a /dev-perl/XML-RSS/XML-RSS-1.620.0.ebuild
parentdev-perl/XMLRPC-Lite: EAPI=8 bump (diff)
downloadgentoo-4dd9670e7f208c361cf3035ad0ec477a8acf52bf.tar.gz
gentoo-4dd9670e7f208c361cf3035ad0ec477a8acf52bf.tar.bz2
gentoo-4dd9670e7f208c361cf3035ad0ec477a8acf52bf.zip
dev-perl/XML-RSS: Version bump 1.62
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/XML-RSS/XML-RSS-1.620.0.ebuild')
-rw-r--r--dev-perl/XML-RSS/XML-RSS-1.620.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/XML-RSS/XML-RSS-1.620.0.ebuild b/dev-perl/XML-RSS/XML-RSS-1.620.0.ebuild
new file mode 100644
index 000000000000..32cdaeb0ebd3
--- /dev/null
+++ b/dev-perl/XML-RSS/XML-RSS-1.620.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=1.62
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="a basic framework for creating and maintaining RSS files"
+HOMEPAGE="http://perl-rss.sourceforge.net/"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/DateTime-Format-Mail
+ dev-perl/DateTime-Format-W3CDTF
+ dev-perl/HTML-Parser
+ dev-perl/XML-Parser
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+PERL_RM_FILES=(
+ "t/pod.t" "t/pod-coverage.t"
+ "t/cpan-changes.t" "t/style-trailing-space.t"
+)