summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/XML-SAX-Expat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/XML-SAX-Expat')
-rw-r--r--dev-perl/XML-SAX-Expat/Manifest3
-rw-r--r--dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.400.0.ebuild52
-rw-r--r--dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.500.0.ebuild52
-rw-r--r--dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.510.0.ebuild54
-rw-r--r--dev-perl/XML-SAX-Expat/metadata.xml9
5 files changed, 170 insertions, 0 deletions
diff --git a/dev-perl/XML-SAX-Expat/Manifest b/dev-perl/XML-SAX-Expat/Manifest
new file mode 100644
index 000000000000..9bd501a39afa
--- /dev/null
+++ b/dev-perl/XML-SAX-Expat/Manifest
@@ -0,0 +1,3 @@
+DIST XML-SAX-Expat-0.40.tar.gz 6510 SHA256 4b477dd7afba6e8d3f6117a28a2012381f8635e5cfb996d3cd4d0ee624c39930 SHA512 71f5419ae677e36f3c4471052944af8dc73fa599538afe077502c1c00a6c39e8c1a387da4d69d36ccaa90235e5ba5adee57c1aea18d0b0c789aa81f82347a0be WHIRLPOOL 3e5a463415da14bf195edeecbc0cda924140b13d449be42613cb345302bdb84359b1c85f5efe23604367991e01064a1aa3d8d7a57f45007b732484739024cc4a
+DIST XML-SAX-Expat-0.50.tar.gz 7090 SHA256 a506e64cf3b6f3828e95085148226be1f3487b46e317c4d362dfdb755e954a12 SHA512 be015e608a923c8d8632c8dd44b6f7780fa3daa7075b1cdb961e45af5da3516826cdbfa198aa6ec52a31c27860830227e6bb6b22344780cbb630aa7ca6f0663f WHIRLPOOL e50438ea881cf435be5f1d73b1f78b07f5c3a45a070e5a2436c780dba864f06bd399130e1b8d731fb4352366018014ffc6d2407df4efc6ffeaffd28ead51442a
+DIST XML-SAX-Expat-0.51.tar.gz 7134 SHA256 4c016213d0ce7db2c494e30086b59917b302db8c292dcd21f39deebd9780c83f SHA512 9cd3c7a1cdf0b0a49ea9f871095984fb67ff54c9e5ed49884c591a450c2662acbd6d0f5232a5720663bcab09ff4f41093d414daa0b72457dc98eea5001270478 WHIRLPOOL bfac47b4e8b3af2b06f49cff868938c97af5a935ebb74bca81e6d0974393dddd02728b7257d11f243967bebd9d2b73e6cea042c0656279ca1ae9a268c5ecd450
diff --git a/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.400.0.ebuild b/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.400.0.ebuild
new file mode 100644
index 000000000000..0b4e08679182
--- /dev/null
+++ b/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.400.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=BJOERN
+MODULE_VERSION=0.40
+inherit perl-module
+
+DESCRIPTION="SAX2 Driver for Expat"
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-perl/XML-SAX-0.15-r1
+ >=dev-perl/XML-NamespaceSupport-1.09
+ dev-perl/XML-Parser"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST=do
+
+src_compile() {
+ export SKIP_SAX_INSTALL=1
+ perl-module_src_compile
+}
+
+pkg_postinst() {
+ pkg_update_parser add XML::SAX::Expat
+}
+
+pkg_postrm() {
+ pkg_update_parser remove XML::SAX::Expat
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}
diff --git a/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.500.0.ebuild b/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.500.0.ebuild
new file mode 100644
index 000000000000..cb04a088daf6
--- /dev/null
+++ b/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.500.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=BJOERN
+MODULE_VERSION=0.50
+inherit perl-module
+
+DESCRIPTION="SAX2 Driver for Expat"
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-perl/XML-SAX-0.15-r1
+ >=dev-perl/XML-NamespaceSupport-1.09
+ dev-perl/XML-Parser"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST=do
+
+src_compile() {
+ export SKIP_SAX_INSTALL=1
+ perl-module_src_compile
+}
+
+pkg_postinst() {
+ pkg_update_parser add XML::SAX::Expat
+}
+
+pkg_postrm() {
+ pkg_update_parser remove XML::SAX::Expat
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}
diff --git a/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.510.0.ebuild b/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.510.0.ebuild
new file mode 100644
index 000000000000..470be2a96ad4
--- /dev/null
+++ b/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.510.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=BJOERN
+MODULE_VERSION=0.51
+inherit perl-module
+
+DESCRIPTION="SAX2 Driver for Expat"
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-perl/XML-SAX-0.15-r1
+ >=dev-perl/XML-NamespaceSupport-1.09
+ dev-perl/XML-Parser"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )"
+
+SRC_TEST=do
+
+src_compile() {
+ export SKIP_SAX_INSTALL=1
+ perl-module_src_compile
+}
+
+pkg_postinst() {
+ pkg_update_parser add XML::SAX::Expat
+}
+
+pkg_postrm() {
+ pkg_update_parser remove XML::SAX::Expat
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}
diff --git a/dev-perl/XML-SAX-Expat/metadata.xml b/dev-perl/XML-SAX-Expat/metadata.xml
new file mode 100644
index 000000000000..521d36d4d52e
--- /dev/null
+++ b/dev-perl/XML-SAX-Expat/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">XML-SAX-Expat</remote-id>
+ <remote-id type="cpan-module">XML::SAX::Expat</remote-id>
+ </upstream>
+</pkgmetadata>